Support » Plugin: Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) » Map tiles still loaded via http instead of https

  • Resolved lisalisa1987

    (@lisalisa1987)



    Hi,
    I recently changed a website from http to https and everything loads correctly except the map images and I can not find the right location to change that to https.
    I get this error:
    Mixed Content: The page at ‘…’ was loaded over HTTPS, but requested an insecure image ‘http://c.tile.openstreetmap.de/tiles/osmde/12/2209/1444.png’. This content should also be served over HTTPS.

    Where do I need to change a setting in your plugin?
    Thanks for your help 🙂
    With nice regards, Lisa

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’ve had the same problem.

    I’d suggest changing the default URLs for each WMS option to https, where supported by the provider. There’s no harm in pulling in HTTPS assets on an HTTP page, while the other way around is obviously problematic.

    If all of the providers support HTTPS, an easy blanket fix is to wrap all calls to ‘_baseurl’ in showmap.php in set_url_scheme().

    Hi Boone Gorges,
    thanks for the tip. All default URLs in WMS Options are already https, but thats not solving it…is there no other way than changing plugin files?
    I think the plugin supports https and it is just a setting I have to make but I couldnt find it…

    With nice regards, Lisa

    @lisalisa1987 – See https://wordpress.org/support/topic/discomap-api-endpoints-have-changed/ – it could be that the URLs you’re using are out of date.

    Plugin Author RobertHarm

    (@harmr)

    Hi Lisa,
    https support for osmde basemaps will be added with the next release – if you like to add this change already now, please edit /wp-content/plugins/leaflet-maps-marker/inc/showmap.php, search for $osm_tile_url = 'http://{s}.tile.openstreetmap.de/tiles/osmde/{z}/{x}/{y}.png'; and replace this line with $osm_tile_url = 'https://tile.openstreetmap.de/tiles/osmde/{z}/{x}/{y}.png';
    best,
    Robert

    lisalisa1987

    (@lisalisa1987)

    @RobertHarm – thanks a lot for your help, that did the trick 🙂
    Thanks all for the support!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Map tiles still loaded via http instead of https’ is closed to new replies.