WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Map tiles on background

[Resolved] Map tiles on background

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author RobertHarm

    @harmr

    Hi,
    the configuration of your custom image map is causing this error. The tiles cant be loaded. Please check the configuration and compare it to other custom basemaps/overlays for example to find a possible error.
    regards,
    Robert

    I can’t understand where is the problem . I generated tiles with MapTiler . These tiles are in a folder with inside 5 folders for each zoom livel (1,2,3,4,5) . I put them in basemap as http://mydomain/folderwith tiles/{z}/{x}/{y}.png . Do you know other softwares to generate tiles ?
    Thanks very much .

    Plugin Author RobertHarm

    @harmr

    I guess there is a problem with map generated by MapTiler – another user reported a similar problem. Will try to add a layer by myself and see if there might be a bug in the current version and if yes, fix this for v3.1. Please be patient.
    regards,
    Robert

    Plugin Author RobertHarm

    @harmr

    Hi again,
    have you configured the map as “custom basemap” or “custom overlay”? If you used “custom basemap”, please set the option “TMS” to true on custom basemap settings. please tell me if this works.
    regards,
    Robert

    Yes , i set it as basemap , tms: tue , continuosworld: true , nowrap: true . I tried several combinations of these options but not work . Do you think is MapTiler ? Thanks .

    Plugin Author RobertHarm

    @harmr

    i did some tests yesterday – maptiler maps showed up on my instance when I set TMS to true. For v3.1 there will also be a TMS option for overlays.
    So I would guess that there might be a problem with your generated tiles or server were you those files are hosted
    regards,
    Robert

    I not use a server to host tiles . Maybe the problem depends by this ?
    This is the link :
    http://fireandswordfans.altervista.org/wordpress

    if you have time take a look to it . Thanks .

    Plugin Author RobertHarm

    @harmr

    I think I understand now – so removing the image for tiles not found would solve your problem? I could add this as an option for custom basemaps in v3.1

    I don’t know . But if i build a simple map only with leaflet script it works properly :

    http://fireandswordfans.altervista.org/maptest.html

    But i need to use your plugin because is perfect for what i want to do . Do you think there’s no way to solve this ? If is a problem of your plugin i’ll wait the new version . Thanks very much .

    Plugin Author RobertHarm

    @harmr

    ok, I understand – will add the option to remove the error tile url for custom basemaps in v3.1

    PS: as I give support for free, I’d appreciate your review at http://wordpress.org/support/view/plugin-reviews/leaflet-maps-marker

    My problem is solved with version 3.1 .
    Thanks very much Robert .

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Map tiles on background’ is closed to new replies.