Support » Plugin: OpenStreetMap for Gutenberg and WPBakery Page Builder (formerly Visual Composer) » All Stamen Map Styles not showing any map, tried all zoom levels

  • Should this be working or is it a known problem? All Stamen map Styles are not working for me. They are not showing any map. On the website using the map plugin I did try all zoom levels. None shows any map.

    • This topic was modified 1 year, 7 months ago by bummtschak.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Step-Byte-Service GmbH

    (@stepbyteservice)

    Thanks for your interest in the plugin.

    It should work and I could not replicate this problem. The Stamen Terrain style seems to support zoom levels up to 15 only, the other Stamen styles work with all levels.

    Do you use the latest plugin version (1.0.7)? Which browser (vendor/version/operating system) do you use? Are you using the Gutenberg block or the Page Builder element?

    Could you open the developer panel of your browser and check the console output for any errors and the network requests of the tiles for statuscodes >= 400?

    Best regards
    Karsten

    Thread Starter bummtschak

    (@bummtschak)

    Hi Karsten, thanks for getting back to me and excuse the late feedback.
    Using 1.0.7 of the plugin.
    Firefox 79.0, macOS 10.15.6
    WPBakery Page Builder

    Tried Wikimedia style, zoom level 17

    When loading the website, console output is:

    Diese Seite verwendet die nicht standardisierte Eigenschaft “zoom”. Stattdessen sollte calc() in den entsprechenden Eigenschaftswerten oder “transform” zusammen mit “transform-origin: 0 0” verwendet werden.

    JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate.min.js:2:552

    Layout-Darstellung wurde erzwungen, bevor die Seite vollständig geladen war. Falls Stylesheet noch nicht geladen sind, kann dies zu einem kurzzeitigen Darstellung des Inhalts ohne Formatierung führen.

    Reloading a few times adds several errors:

    e.g. GEThttps://maps.wikimedia.org/osm-intl/17/70387/43016.png
    [HTTP/2 429 No Reason Phrase 16ms]
    indicating 429 Too Many Requests, running into rate limit

    This error is repeated for all requested png files

    So it makes sense nothing is shown. But why the rate limit is triggered I have no clue. This is a very low traffic site and a small map snippet is embedded on a single page.

    Changing the zoom level to 10 shows some tiles, but the few that would be shown on zoom level 17 are also missing.

    Would that indicate the rate limit is related to specific tiles?

    Another thing: looking at the Reply tab of the failed request I see the following message from Wikimedia Foundation:
    Error: Our servers are currently under maintenance or experiencing a technical problem. Please try again in a few minutes.
    See the error message at the bottom of this page for more information.

    Request from IPv6 address via cp3053 frontend, Varnish XID XXXXXXXXXX
    Upstream caches: cp3053 int
    Error: 429, Too Many Requests at Sun, 02 Aug 2020 11:19:40 GMT

    Testing with Stamen Toner Style, zoom level 10 I am not even getting the error messages.

    So this feels like different errors being at work.

    • This reply was modified 1 year, 2 months ago by bummtschak.
    • This reply was modified 1 year, 2 months ago by bummtschak.
    Thread Starter bummtschak

    (@bummtschak)

    • This reply was modified 1 year, 2 months ago by bummtschak.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘All Stamen Map Styles not showing any map, tried all zoom levels’ is closed to new replies.