• Resolved Charmenoir

    (@charmenoir)


    Hi !

    I tried using the percentage width for the map, cause it’s not responsive without the percentage. But when I use this kind of responsive size it doesn’t work and the map desappears.

    Is there a way to make the map responsive? Cause at the lower resolution it become cutted.

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello,

    I’m sorry to hear that you’re running into this issue. If possible, please provide a link to the site/page in question so we can look into this further.

    Thread Starter Charmenoir

    (@charmenoir)

    Hi! No problem, actually thanks for the plugin.

    This is an example page: http://www.esalta.it/001test/experiments/events/serata-danzante/
    I tried this also on other site with other theme.

    Maybe it’s a problem of the last version, I dont know 😀

    I am not part of support just some dude…

    Try looking at this link and the last post I made.
    https://wordpress.org/support/topic/map-percentage-width/
    Notice in the code… I didn’t apply a percentage to the “height” I used fixed “px” .
    I can’t remember if that was a problem when I investigate the responsive topic..
    But give it a try.

    Good luck
    =======================
    added note here:
    I just tested this on my site… if both height and width are a percentage the map disappears.

    So set width as percentage and height fixed..

    • This reply was modified 6 years, 7 months ago by Robswaimea.
    • This reply was modified 6 years, 7 months ago by Robswaimea.
    Thread Starter Charmenoir

    (@charmenoir)

    Hi!
    Yes if I use only pixel the map works, and I also set up the API Key.
    I tried using widht in percentage and height in px but the map desappears anyway.
    I usually use the google map in this way ( height fixed and width responsive ).

    Thanks for your help anyway! I really appreciate it.

    The problem appears with different themes, with standard and premium.

    Hi
    Another customer here, not support.

    This is how I made the map responsive on our site. Note that you may need to make changes as your theme is likely to be different.

    In the settings, use “Default map width”:360px and “height”:280px (or whatever looks good on your site when using a wide desktop browser).

    In “Single event page format” and “Single location page format” use the following to show the map before other details on the page:
    <div class="child-event-map">#_LOCATIONMAP</div>

    In your child theme CSS or other plugin that lets you show custom CSS, add:

    .child-event-map { float:right; margin: 0 0 15px 15px; }
    
    @media screen and (max-width: 920px) {
        .child-event-map { float: none; margin-left: 0; }
        .em-location-map-container { width: 98% !important; }    
    }

    This will override the inline 360px width that EM sets from the settings. It also puts an extra div around the map that changes float setting here. You can change the 920px to whatever value you want to make the map responsive at.

    Gerry

    PS Rob, your link comes back to this topic.

    Thanks Gerry.. whoops.. here’s the link..
    https://wordpress.org/support/topic/map-still-not-responsive/

    @charmenoir
    I looked at your test site and it looks like you are using default theme Twenty-fifteen,
    and also that you don’t have any other plugins installed.

    I am running a previous version of Events Manager (my main live websites)..
    I went over to one of my test sites… that has the current version EM running and I am seeing problem.

    There are two div statements that contain the map.. one inside the other.
    The first div statement that seems to make the map disappear when a percentage is applied is this one…
    <div class="em-location-map-container"

    The second div statement doesn’t seem to be a problem with percentages…
    <div class="em-location-map-info"

    This all seems to be with a location page or an single event..

    Although… if I use the shortcode for all my locations…
    [locations_map town="Happy Place" width="100%" height="300"]
    I don’t have a problem.

    The theme I am using is Twenty-Fourteen

    • This reply was modified 6 years, 7 months ago by Robswaimea.

    @charmenoir I’m not seeing the map cut off at low-res sizes. Is this still something you need help with, or were you able to find a suitable solution?

    Thread Starter Charmenoir

    (@charmenoir)

    Hi!

    Here i am. I tried the @gerry_c solution and it worked!
    Now the map acts well.

    Thank you very much to you all for your kind and precious help. Rob, Gerry and Jordan !

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Map Percentage Width’ is closed to new replies.