Support » Plugin: All-in-One Event Calendar » Map not showing in single event.

  • Resolved great-taste

    (@great-taste)


    Hi, in a single event post, I’m having trouble getting the map of the event to show (Currently shows a blank map. ex. single event example). I’m using Timely All-In-One Event Calendar 2.5.10.

    I’ve tried inputting Google API keys in the setting – both browser key and server key yielded no success.

    Help would be appreciated, thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Benjamin

    (@bsokic)

    Hi,

    It seems that everything is fine with Google API key, have you tried the troubleshooting guide? http://time.ly/document/user-guide/troubleshooting/first-troubleshooting-step/

    Hi, yes I’ve looked into the troubleshooting guide. Regarding the specific guide about google map not showing, I did make sure that a call to wp_footer() is happening. I’ve also tried deactivating plugins to see if there’s a plugin conflict.

    Could the error have nothing to do with API keys?

    Plugin Author Benjamin

    (@bsokic)

    Please go to Dashboard > Events > Settings and check if “Hide Google Maps until clicked” option is enabled.

    I looked at the settings – “Hide Google Maps until clicked” was unchecked.

    Plugin Author Benjamin

    (@bsokic)

    I need to check your backend, can you please contact us at data@time.ly and we will continue there.

    Thanks,
    Ben

    Thanks for taking the time to look into this. Wanted to ask if there were any findings or possible clues about the matter.

    Hello.
    I have exactly the same problem. Di you fix your problem? It would be nice to share the solution with others.
    I don’t have a footer.php file in my template and I don’t know where to add the code to call to wp_footer()
    Can you please help me?
    Thanks a lot

    Hi funnytoy, this issue has not been resolved yet – I still haven’t reached a solution for this as my map still shows blank.

    • This reply was modified 2 years, 10 months ago by  great-taste.

    I found useful information @ https://theeventscalendar.com/knowledgebase/setting-up-your-google-maps-api-key/

    I also noticed that when I used the copy button for the Google Maps API, there was a space at the beginning and end. I made sure to take these spaces out of the API Key Settings for Timely.

    Also, make sure the Show Map checkbox is checked on the individual event Location Settings. I think it is unchecked by default.

    • This reply was modified 2 years, 4 months ago by  scopie.
    • This reply was modified 2 years, 4 months ago by  scopie.

    Thanks for your help. I ended up doing things a bit manually by making a slight modification to the file “event-map.twig” which is in the location “all-in-one-event-calendar/public/themes-ai1ec/vortex/twig/event-map.twig”. Inside the div container of class “ai1ec-gmap-container”, I added the following code:

    <iframe width="200" height="200" frameborder="0" style="border:0" src="https://www.google.com/maps/embed/v1/place?q={{address}}&key=your_Google_API_key_here" allowfullscreen></iframe>

    Make sure to insert your API key in the “key” parameter of the mentioned code (yes, I ended up hardcoding my key). Also, I believe you can erase/comment-out the following code:

    <div id="ai1ec-gmap-canvas"></div>
    <input type="hidden" id="ai1ec-gmap-address" value="{{ address | e('html_attr') }}" />
    
    <a class="ai1ec-gmap-link ai1ec-btn ai1ec-btn-primary ai1ec-btn-xs ai1ec-tooltip-trigger"
    	href="{{ gmap_url_link | e('html_attr') }}" target="_blank"
    	title="{{ text_full_map }}"
    	data-placement="bottom">
    		<i class="ai1ec-fa ai1ec-fa-search-plus ai1ec-fa-lg"></i>
    </a>
    • This reply was modified 2 years, 4 months ago by  great-taste.
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Map not showing in single event.’ is closed to new replies.