Support » Plugin: Google Maps Widget » Map not showing, broken link says 'Click to open a larger map'

  • Resolved cyberdog64

    (@cyberdog64)


    Hi

    On my site http://woononaosteo.com.au this widget is not yet working.

    I’ve created my Google API key which passes your plugin’s check, and observed the *.woononaosteo.com.au/* asterisk specifiers when getting the credentials with Google.

    On the site the map doesn’t show. Instead I get a broken link to a graphic with the alt tag:

    Click to open a larger image

    When this is clicked the pop-up map says:

    The Google Maps API server rejected your request. This IP, site or mobile application is not authorized to use this API key. Request received from IP address 1.129.96.27, with referer: http://woononaosteo.com.au/

    I find the Google API interface confusing and I’ve done my best to ensure that I have both Static Maps and Embed Maps APIs enabled but nowhere does the Google API thing show in the one place that both credentials apply. (I find all of Google’s GUIs obfuscating in the extreme but that’s probably just me.)

    https://wordpress.org/plugins/google-maps-widget/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author WebFactory

    (@webfactory)

    Hi,
    Yes, Google is not making this easy on anyone 🙁 Thankfully, the message and the cause of the problem are pretty clear – you’ve banned your site from using the API key. Thankfully we can sort that out in no time. Be sure you have these two hosts whitelisted in Google’s Console:
    woononaosteo.com.au/*
    *.woononaosteo.com.au/*

    If you already have those two in but it’s still not working, then, as a temporary measure, leave the API key empty in the plugin – maps will work, and we’ll help you create a new key.

    If you don’t have those two – add them, save and wait for about 10 minutes for Google to propagate changes and maps should start working.

    Apparently I can’t set that whitelisting with a “free”, “ordinary” Google account – I have to pay for an admin account through Google at Work. After following their ‘Find out more’ link I’ve found more that wasn’t what I wanted to find. So I wasn’t able to make that setting.

    Or am I barking up the wrong tree here?

    More importantly, should I feel guilty for daring to build websites without having a Google at Work account?

    Plugin Author WebFactory

    (@webfactory)

    The email you used to login on Console is it @gmail.com or a custom domain?

    It’s a Gmail account, but not an Admin one.

    I presume this is the whitelisting you’re referring to?

    https://support.google.com/a/answer/6160020?hl=en

    If not, could you provide a link to Google’s instructions for what you’re recommending?

    Plugin Author WebFactory

    (@webfactory)

    No, no. Those are Google Apps; you need the API Console. https://console.developers.google.com/apis/ and then when you create a new credential (API key) you set the “Accept requests from these HTTP referrers (web sites) (Optional)”

    Okay, I’ve added a CNAME and TXT confirmation that I own the domain and Google has successfully verified it. Happy days. I’ve also listed the websites in the ‘Accept requests from these HTTP referrers’ fields as *.woononaosteo.com.au/* and *.woononaosteopathic.com.au/*.

    However on the site nothing has changed: the map is still not showing, and it has the same broken graphic link and the same error in the modal map. 🙁

    Plugin Author WebFactory

    (@webfactory)

    Yes, unfortunately, the error is still the same. Until we can figure out what went wrong in the Console just remove the API key from GMW settings – maps will work immediately.

    Plugin Author WebFactory

    (@webfactory)

    Closed due to inactivity. Please reopen if necessary.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Map not showing, broken link says 'Click to open a larger map'’ is closed to new replies.