Support » Plugin: The Events Calendar » Map not loading due to JavaScript error

  • Resolved Gustavo Cieslar

    (@gustavodc)


    Hello,

    the venue map is not loading in my website: http://www.almagroconjesus.org/event/estudio-biblico/

    The problem is an error generated by tribe-events.min.js:

    tribe-events.min.js?ver=4.3:1 Uncaught TypeError: debug.info is not a function

    debug.info(), debug.groupCollapsed() and debug.log() are not recognized. I tested commenting all those calls and the map loaded successfully.

    Why are these errors occurring?

    Thanks,

    Gustavo

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hey Gustavo,

    Sorry you’re having issues, I’d be happy to help you here! 🙂

    First, can you confirm for me that you’ve troubleshooted your Google Maps settings according to this guide, and that you’ve configured the API according to this doc?

    Let me know how this goes, and we’ll work from there.

    Best,

    Shelby 🙂

    Hi Shelby!

    thanks for your kind reply.

    Yes! The map works well when I go to tribe-events.min.js and comment all the debug calls.

    So, the map is not working because of the error generated by the debug call that is stopping JavaScript. If I comment the debug calls, the map works.

    The first call generating an error is:

    debug.info(“TEC Debug: Tribe Events JS init, Init Timer started from tribe-events.js.”)

    Error: Uncaught TypeError: debug.info is not a function

    Thanks!

    Gustavo

    Never mind. I just commented all debug() calls in tribe-events.min.js and tribe-events-bar.min.js.

    If you happen to know why these call are not being recognized, I’ll appreciate it a lot to know.

    Thanks.

    Hey Gustavo,

    I’ll see if I can get one of my colleagues to take a look at this. Did you happen to test for conflicts in this process?

    Best,

    Shelby 🙂

    Hi Shelby,

    thanks for your follow up.

    No, I haven’t had time to test or debug any more. I just commented all the debug calls in the .js files and that solved the problem for now.

    For some reason, the debug function is not being recognized in my installation.

    Thanks!

    Gustavo

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Map not loading due to JavaScript error’ is closed to new replies.