Support » Plugin: WP Geo » Map not displaying – not showing default settings

  • Hi,

    I am using WP-Geo in conjunction with Gravity Forms to allow people to enter a location on an event submission form, here:

    The map is showing on the form but it is not showing the correct latitude and longitude, or the correct zoom level.

    I also cannot get the map to display on the posts. There is a space for the map and <div class=”wp_geo_map” id=”wp_geo_map_2867″ style=”width:100%; height:300px;”></div> is showing in the inspector. I found the bit of code to do with the image width

    div.wp_geo_map img {

    and tried that but no dice. I also tried deactivating and reactivating the plugin but still no deal. Any ideas would be most gratefully received.



Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ben Huson


    It seems to be working fine for me in both Safari and Chrome.
    What browser are you using?

    Have you tried clearing your browser cache?


    I am not seeing a map on the post page, e.g.,

    there should be a map displaying between TTT and A wooha!

    The map is showing ok on the event submission form but the default location is Mali (not where you want to be at the moment!) when I want it to be centred on West Yorkshire.

    I’m using Safari 6.0.2 on OS X 10.8.2. I tried clearing the cache and had a look in Chrome but still not right.


    Plugin Author Ben Huson


    What code are you using to display the map in the Gravity Form?

    What shortcode or template tag are you using to try to display the map on the post page? Is it a post or a custom post type?

    I’m using this

    and I’m using <?php echo do_shortcode(“[wp_geo_map]”); ?>
    in the template. The events are a custom post type.

    I was just looking at the site on my phone (to avoid my ISP’s cache) and it flashed up a notice saying I needed a new Google maps API, where would I get that? The API I’m using is one I got ages ago when I was trying out a few different plugins and I can’t remember where I got it.

    Plugin Author Ben Huson


    WP Geo currently uses version 2 of the Google Maps API which doesn’t work so well on mobile. I’m working on moving it to the latest version – you can test the development version of WP Geo here.

    You may need to specify the post type in your shortcode:

    <?php echo do_shortcode("[wp_geo_map post_type="my_post_type"]"); ?>

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Map not displaying – not showing default settings’ is closed to new replies.