Support » Plugin: Car Route Planner Plugin » Map and list not working correct?

  • Resolved kailew

    (@kailew)


    Hello,
    I’m using this great plugin recently in a work in progress page but have some questions:
    – it seems, that the list with the waypoints is limited to 10? Is it possible to get rid off this limitation?
    – the map doesn’t work on mobile
    – there is always a cookie hint on each usage
    – is it possible to get a link like a bookmark which leads to a before created search so that’s not necessary to do the search again?
    Kai

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author iGuk

    (@iguk)

    Hello, Kailew.

    Sorry for the late reply.

    1. Waypoints are not limited, but there is a limit of route length, which is 15 000 km. Let me know your waypoints list which cause the issue. May be it fails because of large route length.

    2+3. If your page is publicly available, please share the URL here or drop me email to support [at] drivebestway.com. I will look at the issue with mobile map and cookie hint. I can’t reproduce this issues with my test website.

    4. Yes, you can use shortcode with attributes default_from, default_to and calculate_instantly to render particular route on page. You can create several pages with different routes and use it like bookmarks.

    [crp … default_from=”Houston” default_to=”Atlanta” calculate_instantly …]

    Thread Starter kailew

    (@kailew)

    Hello iGuk,

    thx for your reply!
    1. No, the route is – for example – about 2,900 km long, from Berlin to Portugal …

    On your page is the same behaviour
    https://www.besterouten.com/entfernung/?from=Tiergarten%2C+Brandenburg+%2852.5126000%2C13.3597500%2C9%29&to=Odeceixe+%2837.4326800%2C-8.7703200%2C15%29&v=&sm=130&so=90&fc=8.00&fp=1.18

    For me it looks like a Limitation to 10 waypoints …

    2. & 3. Please take a look here:
    https://portucar.de/routenplaner-fuer-portugal/

    thx

    Kai

    Plugin Author iGuk

    (@iguk)

    2 & 3. Ok, I can reproduce the issue. I will investigate it and will return with the fix shortly.

    Plugin Author iGuk

    (@iguk)

    Hello, Kailew.

    Sorry for the late reply.

    2 & 3 should work well right now. I fixed a javascript bug on mobile + disabled cookie consent. Please check.

    Plugin Author iGuk

    (@iguk)

    As for 10 waypoints issue – please describe steps to reproduce the issue.

    Do you add extra points via “Zwischenpunkte” field? And it stop working after 10 waypoints? I tried several routes, but can’t reproduce. Please share the sample of waypoints.

    Or do you add extra points via drag&drop route over the map?

    Plugin Author iGuk

    (@iguk)

    I will close this ticket. Feel free to re-open it or open a new one in case of any problem.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Map and list not working correct?’ is closed to new replies.