Support » Plugin: Flexible Map » Map address returns error: REQUEST_DENIED

  • Resolved garyhooper

    (@garyhooper)


    I am now seeing this error on my pages using Flexible Map. I have upgraded to 1.17.0. I have confirmed that my API key is correct, and that my Google account is in good standing.

    Other suggestions?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author webaware

    (@webaware)

    G’day Gary,

    The error in the console is:

    Geocoding Service: This IP, site or mobile application is not authorized to use this API key.

    This likely means that you haven’t enabled that service for your API key. Because you’re using an address rather than centre coordinates, the coordinates need to be requested from Google — which is done with the geocoding service.

    From your Google API dashboard, click on Enable APIs and Services, and add geocoding.

    cheers,
    Ross

    • This reply was modified 8 months, 1 week ago by  webaware.

    I have both Geocoding API and Maps Javascript API enabled. Both use the same API key, which is in the Flexible Map’s JavaScript API key.

    The Google console shows 100% of the Geocoding API requests being in error.

    It was working fine as of a few days ago…

    • This reply was modified 8 months, 1 week ago by  garyhooper.
    • This reply was modified 8 months, 1 week ago by  garyhooper.
    Plugin Author webaware

    (@webaware)

    G’day Gary,

    In that case, it’s a problem with the restrictions you’ve added to the key. For your website, you should be restricting the key by HTTP referrer, and this is the domain you need for your site:

    kinghooper.com/*

    If you have a staging site or other subdomains, also add this:

    *.kinghooper.com/*

    cheers,
    Ross

    Thank you, thank you. The missing trailing * was indeed the problem.

    Plugin Author webaware

    (@webaware)

    No worries. Why they have to make it so tricky, I don’t know 🙂

    cheers,
    Ross

    I am having a similar issue but restricting the Http referrer even with the * trailer didn’t solve this issue. Sample page with this issue:

    http://ownthesummit.com/beaver-run

    Plugin Author webaware

    (@webaware)

    G’day @ecbuck,

    Please open a new ticket in the forum, rather than adding to a resolved ticket. I nearly missed this!

    Anyway, your site has something (probably a “security” or “optimisation” plugin) that is removing query strings from resources. It has stripped the key from the Google Maps JavaScript API URL. Check for options that mention query strings, and turn those things off. They’re dumb, unnecessary, and ill-advised. Consider replacing the plugin with a better one too 🙂

    cheers,
    Ross

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.