Support » Plugin: Post Content Shortcodes » Many strict standards errors

  • Getting a bunch of “strict standards” errors after installing:

    Strict Standards: Declaration of PCS_Widget::update() should be compatible with WP_Widget::update($new_instance, $old_instance) in /home//public_html/wordpress/wp-content/plugins/post-content-shortcodes/class-post-content-widgets.php on line 13

    Strict Standards: Declaration of PCS_Widget::form() should be compatible with WP_Widget::form($instance) in /home/public_html/wordpress/wp-content/plugins/post-content-shortcodes/class-post-content-widgets.php on line 13

    Strict Standards: Declaration of PCS_Content_Widget::form() should be compatible with PCS_Widget::form() in /home/public_html/wordpress/wp-content/plugins/post-content-shortcodes/class-post-content-widgets.php on line 176

    Strict Standards: Declaration of PCS_Content_Widget::update() should be compatible with PCS_Widget::update() in /home/public_html/wordpress/wp-content/plugins/post-content-shortcodes/class-post-content-widgets.php on line 176

    Strict Standards: Declaration of PCS_List_Widget::form() should be compatible with PCS_Widget::form() in /home/public_html/wordpress/wp-content/plugins/post-content-shortcodes/class-post-content-widgets.php on line 240

    Strict Standards: Declaration of PCS_List_Widget::update() should be compatible with PCS_Widget::update() in /home/public_html/wordpress/wp-content/plugins/post-content-shortcodes/class-post-content-widgets.php on line 240

    https://wordpress.org/plugins/post-content-shortcodes/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Yikes! I’m receiving the same behavior!

    I was so stoked to find this plugin, as it would do exactly what I wanted, but this issue is throwing off lots of styling as well. Also, the optional parms aren’t working.

    Piggy backing here with the same errors. Here’s a back trace on all of them.

    Do you have a public repo for this plugin anywhere? I’ll be happy to fix these myself.

    Plugin Author Curtiss Grymala

    (@cgrymala)

    I’ve just uploaded a new development version (0.4.1) that should fix these issues. Can you try the dev version and see if the issues go away? If so, I’ll make it the new stable version. Thanks.

    That took care of most of them. Two left. Appreciate the quick response. 🙂

    Plugin Author Curtiss Grymala

    (@cgrymala)

    I made one minor change to each class declaration (and added one more changelog note to the readme). I kept the same version number (0.4.1), but you should be able to look at the readme to make sure it has two notes under the 0.4.1 changelog.

    Not sure if it will fix the warnings or not, but it seems to be the recommended way of fixing the warnings without dropping the backwards-compatibility of using __construct() and the self-named method within a class.

    If the issue still isn’t fixed, I suppose backwards-compatibility for older versions of PHP probably isn’t terribly necessary anymore, I’ll just have to check to see which versions of WP stopped supporting those older versions of PHP. Thanks.

    All clear! Thanks Curtiss. I’ve got a blog post coming on GravityWiz.com that utilizes this plugin.

    Plugin Author Curtiss Grymala

    (@cgrymala)

    Awesome. Thanks so much for your help. Looking forward to seeing the new post (and grateful for your Gravity Perks).

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Many strict standards errors’ is closed to new replies.