WordPress.org

Ready to get started?Download WordPress

Forums

Infinite-Scroll
Manual Trigger not loading to the bottom (6 posts)

  1. Oken
    Member
    Posted 1 year ago #

    I'm currently using Infinite-Scroll's Manual Trigger for my website. The manual trigger loads the post as it should, but the trigger itself dosen't automatically move to the bottom of the list when clicked. It seems to just stay in position.

    Has anyone else experienced this and have found a solution or is this just how the manual trigger works?

    Any advice would be greatly appreciated. Thanks in advance!

  2. UNOT
    Member
    Posted 1 year ago #

    I have the same problem...pls help!

  3. Nikho
    Member
    Posted 1 year ago #

    Have you tried to move the trigger outside your posts container ?

  4. benarobinson
    Member
    Posted 1 year ago #

    Yes, as Nikho says, the navigation link must be outside the Content Selector container.

    It should be set up this way:

    <div id="content">
    
    <?php while(have_posts()) : the_post(); ?>
    
     <div class="entry">
      <?php the_content();?>
     </div>
    
    <?php endwhile; ?>
    
    </div>
    
    <div id="navigation">
     <?php posts_nav_link(); ?>
    </div>

    Your IDs may not be the same, and your code may look different, but basically the posts_nav_link(); container (#navigation, in this case) cannot be inside the Content container (#content, in this case.) The plugin adds the new posts to the end of the Content Selector container, so if the Navigation container is inside, it skips over it and adds them after it. If you post links to your sites, I can maybe give you a more specific explanation.

  5. jamo_dodger
    Member
    Posted 1 year ago #

    Works perfectly Ben,

    Basically upload a copy of your index.php to your child theme.

    Find the call for the posts navigation, I am using twenty twelve so it looks like this:

    <?php twentytwelve_content_nav( 'nav-below' ); ?>

    The posts navigation is the newer posts and older posts links that appears at the bottom of your blog page.

    Step 1) take nav-below and enter it into you infinite scroll plugin settings. So navigation selector - #nav-below and next selector - #nav-below a

    Step 2) In your index PHP take the above php and move it to AFTER the closing #content div but before the closing #primary div.

    And thats it

  6. djken69
    Member
    Posted 11 months ago #

    I have similar issue when i use wp them "twenty twelve" with Infinite Scroll, Manual trigger.

    Basically, reference by Mr. jamo_dodger's solutions.
    And i changed the setting of Infinity Scroll Options.

    Step 1.)
    Move <?php twentytwelve_content_nav( 'nav-below' ); ?> like below in them index.php.

    </div><!-- #content -->

    <?php twentytwelve_content_nav( 'nav-below' ); ?>

    </div><!-- #primary -->

    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    Step 2.)
    Setting Infinite Scroll Options by plugin setting page.

    - Content Selector : #primary #content
    - Navigation Selector : #nav-below
    - Next Selector : .nav-previous a:last
    - Item Selector : .hentry

    My work projects using Japanese WP and Work perfect now !!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic