Support » Plugin: WP LinkedIn Auto Publish » Manual share link posts to both Personal Profile and Company Page

  • Resolved linds

    (@lsterling03)


    Hello. If I click the “Share Now” link next to a post, it shares to both my Personal Profile and the Company page. But in the main plugin settings, under Profile Selection, I have only selected my Company page. My personal profile option is grayed out. Does this only apply to auto-publishing? If so, how can I manually share to my Company Page only?

    Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Northern Beaches Websites

    (@northernbeacheswebsites)

    Hi @lsterling03,

    On the post itself, in the metabox, what profiles are selected? Because you can override the defaults on the post metabox itself. This is what I suspected might have happened in your case. Thanks,

    linds

    (@lsterling03)

    Hi, I am using the “Share Now” link in the main Posts table. However, I confirmed, when I click to edit the individual post, in the WP LinkedIn Auto Publish meta box, only our company page is visible. Is the Share Now link in the main posts table not taking the settings into account?

    Plugin Author Northern Beaches Websites

    (@northernbeacheswebsites)

    The Share Now link uses what is set on the post metabox as the first priority. If a post has not been shared before and you click the Share Now link, nothing will be shared even if you have profiles selected by default. For existing posts, go to the post edit page, select the profiles, and then click the share button. Thanks,

    linds

    (@lsterling03)

    Thank you. I’m not sure I understand what you mean by the ‘share now’ link not sharing anything if the post hasn’t already been shared before? The ‘share now’ link does successfully share posts that have not been shared before — but it shares them to both the personal and company page at the same time (even though both the main plugin settings and the individual post settings only show the company page as an option. Can you confirm that is the intended behavior of that link?

    If so… if we want to share to our company page only (manually) — the only way to do that is by opening the post itself and sharing it via the metabox. Is that correct?

    Thanks again for your help.

    Plugin Author Northern Beaches Websites

    (@northernbeacheswebsites)

    What you described is not typical behaviour. But because you are the only person reporting this out of 6000 people I tend to think it might be a miss-understanding rather then a core issue with the plugin.

    The typical workflow is as follows:

    1. From the main plugin settings, select what profile and companies you want to use with the plugin (if you are not planning on sharing stuff personally then don’t activate the profile).
    2. Then you can select the default profiles you want to share with (and this can be overridden from the individual post if desired).
    3. Write the post and click publish and it will be automatically shared. Or click the Share Now button on the post to share again.

    Also I can’t help think that you might have only done 1 test, test what I said above a few times and see what happens. Thanks,

    linds

    (@lsterling03)

    I shared 8 posts on Friday using this method:

    1. In main plugin settings, I connected our account, and both personal and company profiles were visible. I deselected the personal profile so that only the company profile is selected. Automatic sharing is turned off.

    2. I went to the Posts section, and clicked the “Share Now” link on 8 existing posts in the posts table (these posts already existed but had not been shared to LinkedIn before).

    3. The 8 posts shared to both personal and company profiles.

    On Friday, I will have a new batch of posts to share, so I will try again. I will share them from inside the posts this time, rather than use the “share now” link. I was hoping I could use the share now link as that would be faster than opening each post one at a time, but it sounds like I am misunderstanding how that link should work.)

    Thank you for trying to help!

    • This reply was modified 8 months, 3 weeks ago by linds.
    Plugin Author Northern Beaches Websites

    (@northernbeacheswebsites)

    Hi @lsterling03,

    The process I outlined is for new posts. For existing posts, it’s important you check the individual post metabox setting to see what profiles have been selected. Thanks 🙂

    linds

    (@lsterling03)

    Okay, I shared 8 posts again today, this time using the individual post metabox (not the “share now” link in the posts table). The metabox ONLY shows our company page (the personal page is not even an option to select or deselect), and again it shared to both our personal and company pages. I don’t think I’m doing anything wrong. There are no errors in the log. Do you know why this is happening??

    Here are screenshots of our settings (with our name hidden) so you can see how it looks: https://imgur.com/a/R58Vl4J

    Thank you for your help.

    Plugin Author Northern Beaches Websites

    (@northernbeacheswebsites)

    Hi @lsterling03,

    I am not 100% sure on this. Unfortunately through this WordPress forum I can’t ask for login details so I am unable to investigate further. I haven’t had any reports of this nor can I repeat it on my end.

    If you do get the pro version AutoSocial it comes with priority email support where can run diagnostics on your actual WordPress install. Thanks,

    linds

    (@lsterling03)

    Hi again. Just wanted to come back with an update. I copied my site to a staging server, switched to the TwentyTwenty default WP theme, and deactivated every plugin except for WP LinkedIn Auto Publish. My plugin settings are the same as I showed a few posts back (the company page is the only one that is selected). And again, it shared to both my personal and company pages.

    Since it isn’t a theme or plugin conflict, and you can’t recreate this problem yourself — does that mean the server is the problem? I don’t know how the plugin works, but is it possible that our hosting server could affect this? We are hosted on WP Engine if that sheds any light? We have the most recent version of the plugin and WP.

    Thanks for any insight you may be able to share.

    • This reply was modified 8 months, 2 weeks ago by linds.
    Plugin Author Northern Beaches Websites

    (@northernbeacheswebsites)

    Hi @lsterling03,

    I have no idea why this is happening for you, it wouldn’t be server/hosting related. I can’t repeat it on my end, and no one else is reporting it. Personally, I think it has to do with how you are using the plugin. I can only recommend getting the pro version (AutoSocial) and seeing if that works for you, and at least that way I can provide you personal support on your specific site and ensure everything is working ok. If for some reason I am unable to get posts going to either a company page or a personal profile you would be entitled to a full refund as this is an advertised feature.

    Thanks,

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Manual share link posts to both Personal Profile and Company Page’ is closed to new replies.