Support » Plugin: BackWPup - WordPress Backup Plugin » manual backup from https -> SSL connect error

  • Resolved gbeddow

    (@gbeddow)


    Hi,

    I’ve been using the BackWPup plugin for a few weeks and really like it.

    It was working well until I had my hosting provider install an SSL certificate and I switched my public site (and WordPress admin) from http to https. At that point BackWPup started failing at the beginning of (manual) backups with an “SSL connect error”. (The same error appears in the Information tab, next to Server self connect.)

    I tried installing the Disable WordPress Local Connection SSL Verifying plugin (on a couple separate occasions actually), but that made no difference.

    After a lot of trial-and-error I found that if I log into the http version of WordPress admin, manual backups start working again. However, for better security I’d prefer to use this in wp-config.php:

    define('FORCE_SSL_ADMIN', true);

    and of course log into the https version of WordPress admin.

    In case it’s relevant I should also mention I’m using a CloudFlare proxy, configured for “Strict SSL”.

    Is there any way to fix this?

    Thanks!

    https://wordpress.org/plugins/backwpup/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Daniel Hüsken

    (@danielhuesken)

    Did scheduled post work ?

    Yes, I was able to schedule a Cron on the host (not WordPress Cron) to execute PHP something like this:

    <?php
    $_SERVER[ 'SERVER_ADDR' ] = 'xxx.xxx.xxx.xxx';
    $_SERVER[ 'REMOTE_ADDR' ] = 'xxx.xxx.xxx.xxx';
    $_SERVER[ 'HTTP_HOST' ] = 'www.mysite.com';
    $_SERVER[ 'HTTP_USER_AGENT' ] = 'BackWPup';
    define( 'DOING_CRON', TRUE );
    require '/home/mysite/public_html/wp-load.php';
    if( class_exists( 'BackWPup_Job' ) )
        BackWPup_Job::start_cli( 1 );
    ?>

    Just checking back to see if anyone had thoughts on this one.

    Others seem to be having similar problems, but I haven’t been able to find a solution.

    Is the fact it works for a scheduled backup a clue as to cause?

    Any possibility of a workaround for manual backup?

    Thanks!

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    Not directly but you can use WP-CLI.org to making backups. TH support for WP-CLI hase improved a bit in the next Version https://github.com/inpsyde/backwpup/releases/download/3.2.0-rc1/backwpup-3.2.0-rc1.zip

    Thanks.

    I’ve been reading up on WP-CLI. Interesting idea, although a lot of install hoops to jump through to get manual backup working.

    Since my scheduled backups were already using the BackWPup script above in a file on my (shared hosting) server, I was able to invoke the same file from ssh for a manual backup:

    php -f /home/mysite/public_html/wp-content/uploads/backwpup-php/backup-mysite.php

    Still, it would be nice to run a manual backup from within BackWPup itself so you don’t have to fire up ssh, etc.

    I’d be happy to provide more info on the configuration of my WordPress site, test beta versions of BackWPup, etc. I think SSL and related technologies for WordPress – and sites in general – are the future, and will help build a safer internet. Getting BackWPup to work well in this environment seems like a good thing all around.

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    The Problem ist not the general SSL usage. But the usage of the Cloudflare Proxy. And thant brackes the complete WordPress cron and other things that must have loopback connections. MY Webseite works with BAckWPup and SSL but i don’t use Cloudflare.

    You knew all along it was the proxy?

    Interestingly, I’ve tried pausing CloudFlare – bypassing everything it does other than being a proxy – and that still didn’t work when logged into https WP admin. The only thing that works for manual backup from BackWPup is logging in as http.

    CloudFlare provides some very useful security and performance advantages, so making BackWPup work with it would be a big plus.

    WP-cron is no loss to me, depending as it does on activity on the site in order to get things done. Regular server cron is reliable regardless of site activity, and works well for me.

    Hi,
    BackWPup plugin is very usefull n comfortable but unfortunately it doesn’t work with SSL certificate.
    As gbeddow I tried installing backwpup-disable-ssl-verify plugin but with no success.
    The only thing i got is info:
    “The HTTP response test get an error “SSL: certificate subject name xxxx does not match target host name xxxx Not expected HTTP response body”
    Is there a chance to “cure” this?

    regards

    Rodias: It sounds your situation is a little different so, if you haven’t resolved it, you might try starting a separate support question.

    Manuel5cc

    (@manuel5cc)

    Hello there:
    I reached this discussion because I have the same problem and as I can see it’s all about cloudflare. Have you done any corrections with this or is it planned? Will the scheduled backups work anyways? Any other ways to run a manual job?

    Hey guys

    So this is due to the security implemented with CloudFlare’s Free Universal SSL and lack of those ciphers being turned on by default in certain cURL versions.

    Please see my post here for a proper fix and ref URL: https://wordpress.org/support/topic/unknown-error-log-ssl-connect-error-error-35?replies=8#post-8253831

    Cheers
    -Keith

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    I will remove the connection test on next release. So that there is a change that it work.

    Daniel,

    I am having the same problem as gbeddow and I am seeking a final solution and want automated CRON backups on my shared host service. MY host has installed OpenSSL yet no change in manula execution of backup. Generates error message.

    My host recommends another backup plugin instead of backWPup. I would think that you and the good folks at backWPup could quickly fix this. Trust that if this is a recurring and ongoing problem many will abandon backWPup plugin and your product will suffer.

    Is this what you want?

    Best,

    Kevin

    Hi @kpbryce132, can you post exactly the error you are getting? I’m running BackWPup with both SSL as well as Cloudflare, and having no issues with it. If you could post the error, that would be helpful. 🙂

    You may also want to think about opening your own thread just because this one is pretty old and it’ll be easier to not lose track of your issue.

    Hi Brandon,

    Per your recommendation here is the actual error message I receive:

    “Not expected HTTP response:
    WP Http Error: cURL error 35: gnutls_handshake() failed: A TLS fatal alert has been received.”

    Kindly note I am using as shared hosting program, SSL and CloudFlare.

    The host has added OpenSSL to the server where my domain resides. They pretty much closed the issue and washed their hands of it – recommended I switch to the “BackupBuddy plugin”.

    I occasionally get 500 errors on this service which is for WordPress users.

    The fact that it says “http error” should be the clue. All of my site pages are using SSL.

    Thanks for your insight and helpful suggestions!!

    Kevin

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘manual backup from https -> SSL connect error’ is closed to new replies.