WordPress.org

Support

Support » Plugins and Hacks » Online Backup for WordPress » [Resolved] Manual backup failed

[Resolved] Manual backup failed

  • Hi

    I’ve never had a problem before today but my manual backup failed twice. Here is the error I got:

    A filesystem operation failed while processing ‘Database/OBFW_Database.sql’ for backup.
    If the following error message is not clear as to the problem and the issue persists, please contact support providing the complete event log for the activity. Diagnostic information follows:

    Failed at: 346(/home/www/online-casino-info.com/wp-content/plugins/wponlinebackup/include/tables.php)
    An error happened at: disk.php(387)
    fwrite(): supplied argument is not a valid stream resource

    Other info:
    Online Backup for WordPress Plugin Version 2.2.16
    WordPress Version: 3.5
    PHP Version: 5.2.17
    MySQL Server Version: 5.0.51a-24-log
    MySQL Client Version: 1.0
    Mem: 256M; Post: 16M; Upload: 20M; Timeout: 120
    End of Information

    http://wordpress.org/extend/plugins/wponlinebackup/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Online Backup

    @driskell

    Hi faulkwood,

    Was there any other entries in the event log? Can you check?
    Can you try running some more backups and see if this is reproducing every single time or is it randomly happening between successful backups?

    Regards,

    Jason

    Hi Driskell,

    I got the same error today:
    The backup failed: A filesystem operation failed.
    A filesystem operation failed while processing ‘Database/OBFW_Database.sql’ for backup.
    If the following error message is not clear as to the problem and the issue persists, please contact support providing the complete event log for the activity. Diagnostic information follows:

    Failed at: 346(/home/w83467/domains/ottimizzazione-pc.it/public_html/wp-content/plugins/wponlinebackup/include/tables.php)
    An error happened at: disk.php(387)
    fwrite() expects parameter 1 to be resource, boolean given

    Could you please help?
    Thanks

    (at least – it seems the same error – if not and if you prefer me to open a new thread please let me know)

    Plugin Author Online Backup

    @driskell

    Thanks,

    Could you try our tracing version and send us the log it produces? It’ll help us find the problem. Ill just copy paste instructions for you:

    You can download a version 2.2.16 trace version here:
    https://wordpress.backup-technology.com/wponlinebackup-472-tracing.zip

    You’ll need to uninstall the plugin you have installed (you’ll lose your settings so remember to write down any encryption keys!) Then you’ll need to upload this tracing one and activate it.

    Once you’ve set it up again, try running some backups and reproduce your issue. A trace.log file will appear in your FTP folders at /wp-content/plugins/wponlinebackup-472-tracing/trace.log. Please download this file, compress it (Windows, right-click Send To -> Compressed ZIP File, Mac, right-click Compress), then email it to support “at” backup-technology.co.uk and put a link to this topic in the email message too so we know who sent it.

    After we receive it we can work out what is causing your problems and see if we need to make some adjustments to our plugin or if there are some configuration adjustments we can make such as memory usage.

    Regards,

    Jason

    Thanks Jason, I’ll do that and let you know.

    Email sent. Thanks again

    Plugin Author Online Backup

    @driskell

    Thanks.

    Found the problem! Our cleanup code is running sometimes when it shouldn’t it seems. Deleting that file which it needs.

    Apologies for the issue. We will fix it and release 2.2.17 over the weekend hopefully and it will begin working again. Seems an update to the clean up code at some point introduced the problem and it got through our testing. I think it started probably around 2.2.14.

    Regards,

    Jason

    Thanks. I just tried again today and got the same error. Will await the update.

    I’ll wait for the update. Excellent support Jason!

    Plugin Author Online Backup

    @driskell

    Hi,

    Version 2.2.17 has just been released to fix the issue. Let us know if you still have issues after upgrading.

    Thanks,

    Jason

    Plugin Author Online Backup

    @driskell

    You’re welcome marcomancosu 🙂

    It worked fine today! Thanks also.

    I still have the same issue (maybe just similar?) after upgrading to .17. Error message is

    Failed at: 314(/home/content/03/5811303/html/wp-content/plugins/wponlinebackup/include/tables.php)
    An error happened at: compressor_deflate.php(411)
    filesize(): stat failed for [path masked] /obfwZT3jTc

    I rolled back to .15 version and it works.

    Plugin Author Online Backup

    @driskell

    Ill have a look into it.

    Plugin Author Online Backup

    @driskell

    Hi jdcarlson,

    Found the problem. It’s the cleanup code we improved. Missed a couple spots. 17 fixed one of the spots and didn’t fix yours. Apologies for this!

    Can you download the following version and try it out? It will become .18 in a couple weeks time:
    https://wordpress.backup-technology.com/wponlinebackup-494.zip

    Regards,

    Jason

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] Manual backup failed’ is closed to new replies.
Skip to toolbar