Support » Plugin: Subscribe To Comments Reloaded » Managment subcription links don’t work

  • Resolved charlios315

    (@charlios315)


    Hi there,

    I have an issue with the links to the subscription managment pages which you can find under the comment section of each post. Whenever I click on them the link opens, but without the : in https://… so the real managment page doesn’t open and the browser says there’s an error. However when you click on the “Confirm subscription” link you get in your email, the site opens without any problems. When you type in the : manually it works too.
    How can I fix this problem?

    Thank you in advace for your help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi,

    Same for me, whenever a user clicks in the link provided by [manager_link] to be able to manage his subscriptions, he gets an error due to the use of https (I guess).

    When I check the source code of the received email, I can see : <a href=”http://https://etc&#8230;

    Then the URL in the browser looks like https//etc… instead of https://etc&#8230;

    By just adding : in the URL between https and // it works fine.

    Edit : Issue posted here too.

    Something needs to be done to make it work properly, I guess.

    • This reply was modified 3 years, 3 months ago by manu.p.
    • This reply was modified 3 years, 3 months ago by manu.p. Reason: added github issue link
    Thread Starter charlios315

    (@charlios315)

    I thought this was because the shortcode doesn’t work but in the notification mails you get for a new comment the [manager_link] shortcode works. When I check the source code on the website it’s the one you posted, one that should work.

    I solved the problem for now by replacing the shortcode with the acutal link to the management page. But I’d still like to know why it doesn’t work with the shortcode.

    Sorry, I don’t understand what you replied.

    Yes, it’s the URL in the notification mail that’s badly formed. It just can’t be http://https://mywebsite/manager-link_as_provided/etc&#8230;
    It has to be http://something or https://something but not both. Right.

    But so far, I just don’t know what I could substitute to [manager_link] in the so called “Management Email message” in the Notifications setup section.

    So, I just added in this “Management Email message” that the software being bugged, the user’s got to check the URL to correct it in his/here browser and then be able to gain access to his/her subscription management page… Don’t ask, that’s crap!

    Hope a new version correcting this will soon be available!

    Any other plugin doing this sort of comments subscription?

    Guess what? Trying another similar plugin, I just turned off StCR and then on again and… it fell functioning correctly, I mean no http://https://etc&#8230; anymore in the link provided in the “Management Email message”…

    Crossing my fingers now.

    Thread Starter charlios315

    (@charlios315)

    Sorry, I made a mistake in my previous comment about the links. Of course neither the one in the source code nor the one that actually opens will work.

    For me the [manager_link] in the subscription mails works though. Only the link that appears on the page itself under the comment section doesn’t work. That’s why I think it can’t be a problem with the [manager_link].

    As I have a real management page (one you can find within the other pages of my website) I just replaced the shortcode with a normal link to this page so I don’t need shortcodes anymore.

    Good to hear it works again though. Do you think we can close this thread as solved?

    • This reply was modified 3 years, 3 months ago by charlios315.

    Alright, I noticed that when I just typed [manager_link] for the link to be followed for instance in the “Text for subscription” section (or whatever it is in english, I’m using a french version), it was replaced with http://[manager_link].

    I switched to “Text” edition instead of “Visual” and could easily force it to <a href="[manager_link]" rel="noopener">etc...</a>

    Did you check it on your side?

    • This reply was modified 3 years, 3 months ago by manu.p.
    Plugin Author Reedyseth

    (@reedyseth)

    Hi Guys, I apologize for been late to the thread. I still closing some other issue and then I will take a look at yours, I apologize for the inconvenience.

    Regards.!!

    Plugin Author Reedyseth

    (@reedyseth)

    Guys, I think you are duplicating the http protocol in you management link insertion. Take a look at this comment:

    https://github.com/stcr/subscribe-to-comments-reloaded/issues/425#issuecomment-395900136

    And please share a screenshot of you link settings to see how you are adding the links.

    Thread Starter charlios315

    (@charlios315)

    @reedyseth Sorry for the late reply and closing of this thread. I solved my problem by using a real link insteatd of the [manager_link]. However, your link and screenshot were also very helpful. I just tried typing in the [manager_link] where normally the URl is put it and it works too.

    Also thanks to @manup-1 for advising me to switch to the “Text” editor. That worked!

    • This reply was modified 2 years, 11 months ago by charlios315.
    Plugin Author Reedyseth

    (@reedyseth)

    Thank you for closing it. I am glad that all is good.

    Cheers !

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Managment subcription links don’t work’ is closed to new replies.