Support » Plugin: WordPress 2-step verification » ManageWP blocked

  • Resolved kgraversen

    (@kgraversen)


    Hi
    Great plugin – easy to use and important features.

    However, after having installed and activated the plugin, my website loose connection to ManageWP.

    ManageWP is a WP management service. On the WP installation you install a Worker plugin and then you can access certain functionalities from a web based dashboard.

    The dashboard is communicating with the Worker plugin, but after installing WordPress 2-Step Verification this no longer works.

    Please look into this. ManageWP support is interested in helping out if so. Also, ManageWP support whitelisting their IP’s if that could help (https://managewp.com/troubleshooting/general/managewp-ips-can-white-list).

    Best
    Ken

Viewing 11 replies - 16 through 26 (of 26 total)
  • The change from 18 hours ago seems to have knocked off ManageWP again. I can’t sync my websites until I deactivate WP 2-step.

    Plugin Author as247

    (@as247)

    Hi, version 2.1 should working with manage wp 4.6.3 without need any patch.
    I have which current using wp2sv 2.1 and it work for me. Can you provide something more like error message, error log. Or you can try to remove Both wp2sv and managewp and reinstall them.

    Plugin Author as247

    (@as247)

    And can you also let me know which WordPress version and php version you are using?

    ManageWP gives me the message

    “Connection problem 403 Forbidden. It looks like some of our IP addresses are not properly whitelisted in your security plugin or WAF.”

    So I went into my Cloudflare and htaccess whitelists and added several new ManageWP IPs which were not already in there. But the problem persisted until I deactivated WP 2-step. This only started happening after the changes made to the plugin yesterday.

    I also tried removing and reinstalling both plugins.

    WordPress 4.9.8, PHP 7.2.11

    Plugin Author as247

    (@as247)

    Hi
    I have updated to ver 2.1.1 it may fix your issue.
    P/s: 403 error seem related to server configuration. Any error log in server?

    • This reply was modified 1 year, 3 months ago by as247.

    No, I don’t see any. I updated to 2.1.1 but am still getting ManageWP’s 403 error.

    Plugin Author as247

    (@as247)

    Ok, so here are 2 options for you, since i’m not able to reproduce your issue
    1. Back to 2.0.2 version which was working for you https://downloads.wordpress.org/plugin/wordpress-2-step-verification.2.0.2.zip [OR]
    2. add define(‘WP2SV_STRICT_MODE’,true); this will make version 2.1 work as 2.0 (but not tested)

    Both 2 options above required a patch for managed wp worker plugin. (by using ‘wp2sv_trusted_request’ filter)

    (using option 2)

    That worked! Now it’s syncing properly. Thanks!

    Plugin Author as247

    (@as247)

    Ok, that’s good, pls keep WP2SV_STRICT_MODE in wp-config.php so it’s not affected in future updates

    Argh! They just updated the Worker plugin, and now the fix has stopped working.

    Never mind–I was using the wrong code. 😛 Now it’s working.

Viewing 11 replies - 16 through 26 (of 26 total)
  • The topic ‘ManageWP blocked’ is closed to new replies.