Support » Themes and Templates » Manage Theme: Code appears in title!

  • I don’t know why this is happening, but something’s wrong with my installation of the theme S2a. In Presentation>>Themes, I have a nice list of my available themes, all of them installed correctly. But, with S2a, the Title, Version, and Description contain almost all the code from pages within my installation.

    I don’t know any real PHP, all I do is trial and error until I get my layout exactly right, tweaking code in different ways. I may have inadvertantly tweaked something crucial.

    I’ve installed ThemeSwitcher, and, well, when you try to switch to S2a, it craps out.

    See for yourself: Scroll down and click on the “Theme Switcher” dropdown. It reads S2a, and then blah blah blah. All I want it to say is S2a.

    Please help, potential employers will be looking at this site, and it’s got to be perfect!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Probably need a closing */ somewhere in the style.css.

    I looked around and that’s not it. It validates and all. Try deleting the information in the header of the style.css file

    Compare it to the default style.css, I think you will find I’m right. Where’s the closing comment tag after “This is to ease…”:

    Aah. It passes validation because there’s a /* within a /* Sharp eyes, Beel

    Try adding */ after the meta info in the stylesheet

    Added */ to match the default style sheet, and all the other stylesheets, for that matter. Still funky. I think you guys had it, but, now that I’ve added that, well, it should have fixed itself. I logged out/in of WP-admin, cleared my cookies… I’m still not getting it 🙁

    It is a problem with your stylesheet somewhere. Just so you are sure (I tested it on my site), backup the css and copy one from a them that is displaying properly. You will find it works. Good luck tracking down just what and where it is in the css!

    I’d say just upload a new css, but it looks pretty hacked up already 😉

    That last line was like ringing a bell. I bet I figured it out. You are probably hacking it in a word processor or inappropriate editor. Try a text editor and convert to Unix line feeds.

    Yep, that’s probably it. As sonn as I ran the css through Editpad and converted the line feeds, it was fixed.

    I think a problem like this has come up a couple times before when someone edited their css in dreamweaver. I think you may just need to open the css in a plain texteditor and resave and it will fix itself.

    But… I thought Dreamweaver was a good witch? 🙂

    I used to write html in TextWrangler and upload with MacSFTP. Now I use Dreamweaver, Education, 2004. Maybe there’s a setting somewhere I need to chaaaange….

    But you are right, I do hack apart my code. It kind of looks ugly from time to time. Thing is, I spend so much time tweaking/uploading/refreshing that when it FINALLY works, I’m too pooped to clean.

    Which is pretty much what Beel said, but I just wasn’t really paying attention… 😉

    Yup, Dreamweaver strikes again. What the heck does it do to the css?!

    I opened it in both TextWrangler and TextEdit, added some stuff then resaved it as something else entirely, then as style.css. Made sure it was un-associated with Dreamweaver on my machine.

    Still. Doesn’t. Work.

    I won’t blame you guys if you stop trying. I think it’s just some DW has botched on that particular theme, and it’s hard to go back. Besides, Random Image turns out to be a much nicer theme, and allows me to do a more dynamic layout, yes?

    If that’s a no, tell me why 🙂

    Send me the css and I will fix it for you in Editpad. I had saved yours and then converted the line feeds and it worked on my test site. BoulderBill – at – comcast – dot – net
    Gotta go for my bike ride but I’ll get to it when I return.

    yo willthethrill327,

    these guys have got it – i’ve been scratching my head on this one for an hour before i stumbled across this page.

    are you using DW on a mac too? this is a round-about way of sorting it out but it fixed mine – upload it, look at it in your browser – then save it to replace your current css. open it up in BBEDIT NOT DREAMWEAVER and paste in your code. maybe textedit too – i didn’t try. but yeah it seems to be dw that spanks it.

    nice one guys!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Manage Theme: Code appears in title!’ is closed to new replies.