Support » Plugin: Newsletter » Manage subscription/Unsubscribe links not working in emails

  • I have version 5.6.9 installed. When I send the mailers, the ‘Manage subscription’ or ‘Unsubscribe’ links do not work from inside the email – I tested in both gmail and yahoo. But when I view the same mailer directly in browser, the links work perfectly. What’s strange is that these links work fine in emails when I send the Newsletter to my ‘Test’ gmail account. Of course I really want them to work from inside the emails when they’re sent out to real subscribers. I’m stumped 🙁

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Stefano Lissa

    (@satollo)

    Hi, probably those email clients are blocking the links in your emails. Possibly, since the email is HTML, add a real link, linking a word with the {unsubscribe_link} (if not already done).

    Stefano.

    Thank you for replying! Below is the links code I am using in my Newsletter, which is not working.

    <a href="{profile_url}">Manage your Subscription</a> | <a href="{unsubscription_url}">unsubscription</a>

    • This reply was modified 1 month, 2 weeks ago by  Setu.
    Plugin Author Stefano Lissa

    (@satollo)

    The code is perfect, so the email clients are blocking the links… probably they don’t trust your emails. Ask your provider if it has setup (correctly) the SPF records for your domain since you’re sending emails from your blog and they are not correctly rendered by webmail clients (specify that they block links).

    Stefano.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.