Support » Fixing WordPress » Manage Media Library Page has No Rows

  • Mediatricks

    (@mediatricks)


    I upload images and go to Manage – > Media Library and I see a few rows of images. At the top of the page it says Images (5)

    I add a few more images and return to Manage -> media Library and I see a blank page beneath the image count – Images (9)

    I have checked the database and all the images are there. They are dsiplaying in posts but something seems to be crashing the upload.php page in wp-admin as the rows of images do not display.

    Cannot pin it down to unslashed quote marks in descriptions, or titles. Might be something to do with Exif data??

    I have noticed that the Upload Facility screws up if you try and upload an image with a space in the filename (or a %20)

    Anyone else facing the same. I can’t edit or delete my images without going into phpMyAdmin which is REALLY annoying and can’t seem to do anything to get my image rows back!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Mediatricks

    (@mediatricks)

    UPDATE: It is definitely something to do with the Exif data or metadata. When I emptied the post_meta table of all the refernces to image attachments my Manage Media Library page displays correctly with a row for each image – but the image thumbnails are now blank in each row.

    I’m having the same issue on three different site all hosted on an IIS Server.
    I’ve narrowed it down to pdf and mov files. As soon as I add either file type, none of the images show up. If I click on ‘Images (9)’ then the images show up but if I click on ‘Video (1)’ or ‘pdf (1)’ I get nothing.

    The _postmeta wp_post_metadata for the mov and pdf files is a:0:{}
    Compare that to a jpg

    a:5:{s:5:”width”;i:440;s:6:”height”;i:215;s:14:”hwstring_small”;s:23:”height=’62’ width=’128′”;s:4:”file”;s:66:”C:\xxxx\root\fish/wp-content/uploads/2008/03/apexprdlogo.jpg”;s:5:”thumb”;s:25:”apexprdlogo.thumbnail.jpg”;}

    If I access the Media Library through the Manage>Posts>Add Media it all works as it should.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Manage Media Library Page has No Rows’ is closed to new replies.