WordPress.org

Support

Support » How-To and Troubleshooting » Manage->Posts page missing

Manage->Posts page missing

  • In my WordPress Admin Panel, the “Posts” page (Under the tab “Manage” and then under the subtab “Posts) is missing some content, meaning that the header is there, but none of the posts show up. This is indeed quite annoying to not be able to edit any of the posts I made, unless I follow the link from the actual blog. I have tried re-uploading the edit.php file, which is the one associated with this page, and nothing happens.
    Anyone know what this issue could be? I certainly do not want to have to reinstall my wordpress, as that would be tedious and knowing myself, I’d probably make a mistake.
    The link to the blog is http://www.nerdnewsradio.com.
    Here is a screenshot:
    http://img61.imageshack.us/img61/3667/safari001yv0.jpg
    Thank you very much.

Viewing 15 replies - 1 through 15 (of 16 total)
  • What if you try it in another browser? Safari is known to have all kind of issues in the admin panel.
    Also, you don’t really need to re-install the whole blog if it is related to some corrupted files: just delete the wp-admin directory and upload a new fresh copy of it.
    (New means – new download, new unzip, new upload).

    Did it ever work?

    Tried it in firefox, same thing. And this did work at some point. It seems to have just happened recently. Meaning in the past month or so. If I delete and re-upload the wp-admin directory, what kind if information would be lost, if any?

    Nothing. (After at least a month… or more) you should already know that all your content is stored in the database – nothing is stored in files!

    Deleted and re – uploaded folder wp-admin. Still the same thing. Could it be an issue with plugins? or some part of a theme? (I doubt it)

    Theme – not likely (unless it’s an admin theme).
    Plugins – very much possible. Try to deactivate them all, then activate one by one to see when the error kicks in.

    I don’t have many Plugins in my panel, I deleted most of them, because I had no use for them. I deactivated all of them, and the issue persists. All I have are Akismet, WordPress Database Backup, Sidebar Widgets, and wp-cache. They’re all uninstalled. Anyone have any ideas? In my FTP, there are a lot of extra directories, backup directories that my host puts there whenever something is upgraded. Could those be creating confusion? Thanks so much again.

    1. Keep only the latest backup – and keep it somewhere else, e.g. your computer: if the server crashes the backups would be gone, too. (But this is not likely to cause the problem, just a general advice.)
    2. I’d try to upload a fresh copy (new download, new unzip, new upload) of the wp-admin folder.

    1. I’ve been deleting the backups, it takes a while via ftp.
    2. I’ve uninstalled all the plugins
    3. I’ve uploaded a fresh copy of the wp-admin folder, but I’ll try again
    4. I’ve just upgraded to WordPress 2.0.5

    Any ideas now?

    Re-Uploaded. Could there be a problem within one of my posts? Perhaps a file I link to, or something of that nature?

    Anyone? Database issue possible? Issue in one of the posts? It’s starting to get really annoying, to not be able to view that information. Thanks to anyone who can help me fix this issue.

    I seem to have fixed it. I found that if I remove all the apostrophes (‘) from the posts, the Manage->Posts page is back. Weird. Anyone know why this might be?

    Chris_K

    @handysolo

    Wow!

    That’s truly an odd fix. But thanks so much for posting it, in the event that this happens again.

    I can guess that it happens because apostrophes can munge up a SQL query nicely. But typically, they’re handled in the code. I doubt I have a post that doesn’t have one…

    Have you done any modifications to your WP “core” files?

    Isn’t that what “htmlspecialcharacters” is supposed to fix?

    WPChina

    @wordpresschina

    I have had intermittent problems like this too with some admin pages not appearing. The problem is fixed when I increased cache in the php.ini and/or upgraded my mysql/php. Again, it seems like a weird fix, but it worked for me a couple times.

    Yeah, I went for the posts, because it was that page that was missing, but I don’t believe I have done any modification to the core files. I will take a closer look today.

    Also, about “htmlspecialcharacters”, How might I use/activate those?

    Thank so much.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Manage->Posts page missing’ is closed to new replies.
Skip to toolbar