Support » Plugin: Yada Wiki » Man I wish this worked better

  • This plugin is perfect for what I want to do except that private pages don’t show up in the TOC, even when you are logged in and can otherwise navigate to them. Since 80% of my wiki pages need to be private, this won’t work for me.

    Rats.

    • This topic was modified 1 year, 5 months ago by  pjpark.
    • This topic was modified 1 year, 5 months ago by  pjpark.
    • This topic was modified 1 year, 5 months ago by  pjpark.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author dmccan

    (@dmccan)

    That might be something I could tweak. Could you explain the conditions? Are they password protected pages or are you using a plugin to make them private?

    Plugin Author dmccan

    (@dmccan)

    That might be something I could tweak. Could you explain the conditions? Are they password protected pages or are you using a plugin to make them private?

    I’m just setting visibility to Private in the publish settings when I create the wiki page.

    Plugin Author dmccan

    (@dmccan)

    OK. So private is editor or admin.

    https://codex.wordpress.org/Content_Visibility

    I’ll take a look at that this weekend. It seems like the permissions check should already allow this and it must have been an oversight. Sorry about that.

    Crap. Never mind. WordPress only allows admins to read private pages. It would still be nice to have everything show up for admins, but I had to get yet another plugin to allow more granular control.

    Plugin Author dmccan

    (@dmccan)

    OK. Thanks. Happy WordPressing.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Man I wish this worked better’ is closed to new replies.