Support » Localhost Installs » MAMP site redirects to ssl protocol error

  • RachelHKay

    (@rachelhkay)


    I’m trying to get a working local copy of an existing website to work in MAMP so that I can test for PHP 7 compatibility. I’ve got the site itself displaying, and I can navigate the site, but when I attempt to login at either http://localhost:8888/mysitefolder/wp-admin or http://localhost:8888/mysitefolder/wp-login.php I’m redirected to an ssl protocol error in Chrome, and in Safari I’m told it can’t open the page. For whatever reason when I attempt to load either of those URL’s the browser tries to change the http to https so it doesn’t work.

    The live site has an SSL certificate that I manually upload through Let’s Encrypt, but I don’t want or need SSL on the local site. All URL’s in the database are reading http://localhost:8888, but I don’t know why the browser tries to redirect to https.

    I’m using MAMP 4.2 if that helps. Any help with this issues would be greatly appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • shurjastoit

    (@shurjastoit)

    In localhost disable ssl. You can change the link from phpmyadmin. Just change https to http.

    I don’t have MAMP Pro, which as far as I know has the ability to disable ssl. From what I’ve found for MAMP enabling ssl would require a lot of configuration, which I’d rather not do just for one site.

    As far as phpMyAdmin goes, the URLs for both ‘siteurl’ and ‘home’ have already been changed to http://localhost:8888/myfolder. When that didn’t work I ran a query that I found through another search to change other URLs in the database from https://livesite to http://localhost:8888/myfolder. I even attempted to force http://localhost:8888 in wp-config, but that also did not work.

    I’m really stumped as to why the site still tries to load https when I attempt to go to wp-admin and wp-login.php.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.