Support » Fixing WordPress » MAMP localhost 500 error

  • Resolved bibliofille

    (@bibliofille)


    I’m getting

    The other three local sites I have are working fine, however, so I think there’s an issue with the site itself and not the server. But I’m not sure what it is.

    I went to the wp-config. file and turned on debug mode for the site I’m having issues accessing and I see the following error messages:

    Strict Standards: Declaration of c2c_CustomPostLimits::options_page_description() should be compatible with C2C_Plugin_034::options_page_description($localized_heading_text = ”) in /Users/labedzde/Documents/Sites/designsponge/wp-content/plugins/custom-post-limits/custom-post-limits.php on line 49

    Warning: require_once(/Users/labedzde/Documents/Sites/designsponge/wp-includes/widgets/class-wp-widget-search.php): failed to open stream: No such file or directory in /Users/labedzde/Documents/Sites/designsponge/wp-includes/default-widgets.php on line 17

    Fatal error: require_once(): Failed opening required ‘/Users/labedzde/Documents/Sites/designsponge/wp-includes/widgets/class-wp-widget-search.php’ (include_path=’.:/Applications/MAMP/bin/php/php5.5.14/lib/php’) in /Users/labedzde/Documents/Sites/designsponge/wp-includes/default-widgets.php on line 17

    I have no idea what these mean. The local site was working just fine until I connected it to bitbucket and began version control. I tried setting up version control using SourceTree, but the codebase is so large, I think it began timing out, so I just set it up through command line instead.

    I wonder if I accidentally did something during that process to mess things up?

    Any advice would be much appreciated!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The Fatal error message holds the answer. It is saying that it cannot open /wp-includes/widgets/class-wp-widget-search.php which likely means the file is missing, though it could also be a permissions issue.

    Assuming the file is missing, it means that something went wrong during the install and some of the files are missing, as I checked and that file exists in the download of the current version of WordPres.

    Thread Starter bibliofille

    (@bibliofille)

    Yes, I somehow must have deleted that file. I pulled it from the live site and that fixed it.

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘MAMP localhost 500 error’ is closed to new replies.