Support » Fixing WordPress » MAMP 'Error Establishing a Database Connection' after edit wp-config

  • Resolved phaik kee

    (@phaik-kee)


    Hello experts,

    I’m using MAMP and love it. Have no problem on connection.

    But i have been trying so hard to get it live. In the process of doing so, I edited (with TextEdit) wp-config for the purpose of matching with the db, username and password of wordpress in live host.

    When I returned to MAMP and changed to original DB_NAME, DB_USER, DB_HOST and DB_CHARSET, the ‘Error Establishing a Database Connection’ came out.

    Anyone has any idea what happening?

    I checked on the file. It has comment about debugging at the end.

    Lee

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator t-p

    (@t-p)

    In nutshell, you’re getting this error because WP is unable to establish a database connection. Reason why WP is unable to establish a database connection can vary. It could be that your database login credentials are wrong or have been changed. It could be that your database server is unresponsive. It could be that your database has been corrupted. Majority of the times this error happens because of some sort of server error. Also, there could be other factors as well. To troubleshooting this problem:
    – double check your wp-config.php file settings for the database name, database username and database password, and the host name (e.g., “localhost” Vs. something else). This is where most errors occur.
    – Then make sure wp-config.php is in right location.
    – Then check that you don’t need to change the database host from “localhost” to something else. You can get that info from your hosting provider.
    – Check you have actually created a database with the same database name as is in your wp-config.php file.
    – Last, but not least, if all that information is correct your database probably has a problem with it.
    – There are also many threads on this topic on these forums: http://wordpress.org/search/Error+establishing+a+database+connection?forums=1

    The host name is ‘localhost’ as it is in MAMP. Double check db name ‘mysite’ , db username ‘root’ and db password ‘root’. wp-config is the folder ‘mysite’.

    In http://localhost:8888/mysite/
    Blank page with ‘Error establishing a database connection’ message.

    Can I put the wp-config here. It does have some weird script appeared from no where.

    <?php
    /** Enable W3 Total Cache */
    define(‘WP_CACHE’, true); // Added by W3 Total Cache

    /**
    * The base configuration for WordPress
    *
    * The wp-config.php creation script uses this file during the
    * installation. You don’t have to use the web site, you can
    * copy this file to “wp-config.php” and fill in the values.
    *
    * This file contains the following configurations:
    *
    * * MySQL settings
    * * Secret keys
    * * Database table prefix
    * * ABSPATH
    *
    * @link https://codex.wordpress.org/Editing_wp-config.php
    *
    * @package WordPress
    */

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘mysite’);

    /** MySQL database username */
    define(‘DB_USER’, ‘root’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘root’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);

    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define(‘AUTH_KEY’, ‘3BC%[;7Z,Hhz+kF>Tkwn>G,y!f}D7z4Xst@%d#>pl4k<#NVnS/JSF!{9zlgl$JF-‘);
    define(‘SECURE_AUTH_KEY’, ‘dEc+S X2^A_.~_c|#F4@2g!sxnsR.q{~v4urk*|I%xHab!yE!i agN+uKGK|3B-‘);
    define(‘LOGGED_IN_KEY’, ‘bcVe{-%s<MUX7xn,ALsNvpl&Zz7YS_-hTQQ]-K,>)fBJS5%:g-}.I]F+|YXQ+N’);
    define(‘NONCE_KEY’, ‘m)n1d%A$I<`zYHNpNC {(D.} p%g*B v(>va%Fq3w+s5X-wG$+Vy(FNSZzc$i 1O’);
    define(‘AUTH_SALT’, ‘+8ooC5pSH78=?@P87YV)=[d* soP@zu?3JZm8Dh.fO,G8>VP.<Uf)sGe^Sl4|PF@’);
    define(‘SECURE_AUTH_SALT’, ‘T=AR@QT.R],p#uItd/Vt+#&xe-3EU|Fv@=gntV?t_`[}F0mj:(^DCq<!AKlx!I<[‘);
    define(‘LOGGED_IN_SALT’, ‘>)?;3mLVvZ1)ljR;AU| _825M_Z0Ykzfx 8@Yd Q3p7JEj_B${qhbxU>zkBwzc;q’);
    define(‘NONCE_SALT’, ‘1Z>e>5{k;3Bcv|%QAZCbd01/)<_-,3X}1tn>;~V<iABM6F–#4$kK>NJ<ec~G0-H’);

    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each
    * a unique prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = ‘wp_’;

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    *
    * For information on other constants that can be used for debugging,
    * visit the Codex.
    *
    * @link https://codex.wordpress.org/Debugging_in_WordPress
    */
    define(‘WP_DEBUG’, false);

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

    point your browser to localhost:8888/phpmyadmin and check out the database
    you might have a spelling mistake or a concatenation issue

    The database is ‘mysite’.

    I noticed that under the the column of collation are ‘utf8mb4_unicode_ci’. Is this the culprit?

    The wp-config :

    ‘/** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8’);

    Its an SQL issue I believe, make sure MAMP is running the latest PHP and SQL versions if not update right away

    MAMP Version
    3.5 → Your version is up-to-date.

    PHP 7.0.0

    Sorry I don’t know the matter of SQL. How do i tackle it?

    If you don’t know then I don’t know either man
    sorry to be harsh
    screen shots would help a lot in this case
    from what you’re saying everything should be fine, maybe reboot your Mac and see what happens. Also try turning MAMP off and back on.

    Thanks for the reply Neo.

    Thanks Tara for the quick first reply to my post.

    Reboot my mac. On off MAMP from time to time.

    Regarding the matter of my 3rd post which is utf8mb4_unicode_ci in localhost:8888/phpmyadmin. I did not see where to upload screenshot here but able to find a site for the purpose.

    [url=http://postimg.org/image/bcy6tgd9l/][img]http://s20.postimg.org/bcy6tgd9l/Screen_Shot_2016_01_21_at_7_19_16_AM.jpg[/img][/url]

    Here you go the right link.

    http://postimg.org/image/bcy6tgd9l/

    Moderator t-p

    (@t-p)

    Regarding the matter of my 3rd post which is utf8mb4

    If the server supports it, you probably want to use “utf8mb4” to get full Unicode character support. This includes 4 bytes characters that the normal utf8 will not support.

    Thanks Tara.

    At least safe to go for this part. I will check around on the other possible issues!

    Both of you were been very helpful.

    Hi, Im also having a similar problem.
    I get this message after adding the database and user information provided by my host in the wordpress installation
    Error establishing a database connection
    I created a database with the same name provided by my hosting in my phpadmin of mamp.
    In the wp-config file I also filled in all the info that was provided by my hosting.
    What could it be that I´m doing wrong?
    I wrote to my hosting to see if it was a network problem, but I don´t think that is it.
    Thanks in advance..

    • This reply was modified 2 years, 11 months ago by beweme.
Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘MAMP 'Error Establishing a Database Connection' after edit wp-config’ is closed to new replies.