MAMP: Blank Page when i enter http://localhost:8888/wordpress (3 posts)

  1. bdb5424
    Posted 1 year ago #

    Greetings all,

    I can not access the wordpress login page after installing wordpress into my local server. I am using MAMP and have followed all the steps based on other posts. Checked and double checked, still can't get it to work.

  2. ancawonka
    Posted 1 year ago #

    Hi there,

    You are getting a blank page because of a PHP error. It's impossible to tell from the blank screen what the problem is.

    Here are some things you can try:

    (1) Go to your wp.config.php file and set WP_DEBUG to true. (http://codex.wordpress.org/Editing_wp-config.php). This should display a whole bunch of messages on your screen, indicating something about the error.

    (2) find a debug.log file in your wp-content folder (this doesn't always happen - generally you have to have debugging turned on)

    (3) Look at your MAMP server log files (in /Applications/MAMP/logs), specifically php_error.log. That might also give you some ideas about the error.

    Once you can see the error, post it here, maybe we can help.

  3. pesca411
    Posted 1 year ago #

    Hello Everyone,

    I am also setting up a local host site using MAMP. I was able to mirror the themes of my live site. All the themes can show a Live Preview, however, the current active theme from the live site (executive-wp) will not load. I was getting a blank page. Thanks to ancawonka I now have an error to go with that blank page. This is the code I am getting:

    Fatal error: Cannot redeclare boolval() in /Applications/MAMP/htdocs/wordpress/httpdocs/wp-content/themes/executive-wp/_admin/functions-setup.php on line 218

    I also noticed that my media Library is empty. Don't know if that is connected, just trying to give as much info as possible.
    I appreciate any help/ideas anyone may have to help me solve this.
    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic