Support » Plugin: Anti-Malware Security and Brute-Force Firewall » Malware found but can't delete

  • Resolved leigh76


    Your plugin finds the malware on, but when I click the remove button, I get the following errors:

    fixing /home/itcacoz/public_html/student/wp-content/themes/cold-theme-powerful-wordpress-theme/cold/lib/timthumb.php …
    Fatal error: Cannot use object of type WP_Error as array in /home/itcacoz/public_html/student/wp-content/plugins/gotmls/index.php on line 146

    When I log into the site, the WordPress dashboard RSS feeds on (incoming links, Plugins, WP Blog) says

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in /home/itcacoz/public_html/student/wp-includes/SimplePie/Item.php on line 1490

    I upped the memory allocation in the config file to 64MB then upped it again to 128 and still not working.

    Host provider has blocked curl_exec() if that helps

    I managed to fix an identical site ( which had the same malware infection

    Any ideas?



Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Eli


    Yes, on line 146 my plugin is testing the result of a wp_remote_get() call that gets the newest version timthumb to replace your outdated version. This call is failing because, as you said, your Host provider has blocked curl_exec().

    You can manually download the latest timthumb.php here:
    use it to replace the old file:

    Let me know how that works for you and if you need anything else.

    Aloha, Eli

    Thanks, all working.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Malware found but can't delete’ is closed to new replies.