WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Malicious code in my theme?

[Resolved] Malicious code in my theme?

  • Hi,

    I just started the topic “Malicious code?” but my post didn’t appear in the topic so I’m trying again.

    I just recently started a blog and installed a theme called Ascetica.

    I installed the theme directly through the dashboard in Appearance -> themes > install themes where I searched for it.

    Now last night I read up on WordPress security etc. and stumbled upon a article that recommended you scanning the code for various male-ware. So today I did scanned with three different plugins called, Theme Authenticity Checker, Exploit Scanner and Theme Check and I got some troubling results with several lines of code being red flagged but I have no idea if the lines are dangerous and/or if/how I should fix it.

    I would appreciate some guidance on what to do,
    Regards RockyJoe

Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Thanks for the tips. I disabled some plugins and then ran the scan again and now everything is back to normal. At least it looks like it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Malicious code in my theme?’ is closed to new replies.