WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Malfunction with PHP upgrade

[Resolved] Malfunction with PHP upgrade

  • My web hosting provider recently forced me to upgrade from PHP 2.2 to 2.4. With this upgrade Jetpack causes my theme to malfunction. The theme works fine when I disable Jetpack.

    The error occurs when I open a post from the home page. It causes the image in the post to show a few times at the top of the page with the rest of the page loading below this so that I must scroll down to see the page as it is supposed to be seen.

    any help appreciated.

    http://wordpress.org/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 21 total)
  • I have been forced to disable Jetpack until this issue can be resolved. Sadly that also means I also lose all of the functionality that comes with Jetpack as I now use Jetpack to replace many of the different plugins I used to use individually.

    I have reactivated Jetpack so that anyone who can help may see the issue themselves.

    My site is located at http://photography.greff.co

    Thank you.

    sorry should say PHP upgrade from 5.2 to 5.4 above.

    WPyogi

    @wpyogi

    Forum Moderator

    Do you have the same issue on a default theme?

    Have you tried deactivating your other plugins?

    I have tried deactivating all the other plugins; it only occurs when the Jetpack plugin is activated.

    I have deleted and re-installed both Jetpack and the Theme. The issue persists. The issue does not occur with a default theme.

    WPyogi

    @wpyogi

    Forum Moderator

    The issue does not occur with a default theme.

    I see you already have a thread on the theme’s forum – looks like it hasn’t been updated in a more than a year, so that’s likely the problem.

    Plugin Author Jeremy Herve

    @jeherve

    For reference, here is the other thread about this problem.

    I installed and activated Picturesque on a test site, and couldn’t reproduce the issue.
    Have you made some changes to the theme since you installed it? If so, could you try to install a fresh version of the theme, and let us know if it helps?

    If you still experience issues, you might want to comment add_theme_support lines in the functions.php file, one at a time, and see if one of them creates the problem. To comment a specific line, at // in front of it. You can look at line 57 for an example:

    //add_theme_support( 'hybrid-core-seo' );

    Let us know if you find out more about the problem!

    Thank you for your reply. I am baffled by the issue.

    I then deleted the theme. I went so far as to delete all of the files via FTP client to ensure the entire theme folder was deleted from the server. I then did a fresh install of the theme via wordpress (Where I searched for the theme in wordpress and had it download and install the files directly from wordpress.org. The issue persisted.

    I created another test site on my network to check if the issue would also occur there. At first the issue did not occur there when using the theme and Jetpack. However once I connected Jetpack to wordpress.com the issue also began to occur.

    I also completely deleted jetpack via FTP so that all of it’s files were removed, and did a clean re-install of Jetpack. Once I reinstalled jetpack the problem returned. When Jetpack is no activated there is not issue. These are clean installs of both the theme and the plugin. Zero alterations.

    The issue also occurs with my Test Site I just created on my network. There are no other plugins running on this test site. All I have done is create one post for which the issue occurs.

    Plugin Author Jeremy Herve

    @jeherve

    Could you try to comment out the theme features as I mentioned earlier, and let me know if you can narrow down the issue to a specific feature?

    You might want to do the same with Jetpack: deactivate each Jetpack module, one at a time, and let me know if the issue disappears when you deactivate a specific module.

    A few things I have noticed. The issue only occurs on posts where I have uploaded the image using the media upload for that post and that is the only post with the image. Or also it will occur if I upload and image to the image library, it will occur on the post where I use the image the first time. If I insert that image into a second post the issue will not occur.

    If I create a new image post, and insert in that post an image which has been uploaded elsewhere, the issue does not occur. Therefore the two posts are essentially identical. The only difference is that in one I uploaded the image to that post and the image is therefore “linked” to that post somehow, it occurs on the post it is linked to. but does not occur on the second post which is identical otherwise.

    For example: The first place I use this image HERE the issue occurs. The second time I use that image HERE. The issue does not occur. The two posts are identical otherwise.

    The issue does not occur on posts which only contain a gallery.

    I attempted to comment on each of the theme features. A few caused the theme to not function at all, others made no difference with the issue. I will see about doing the same with jetpack.

    I have worked through deactivating the Jetpack Modules. I have narrowed the issue down to the “Sharing” and “Publicize” modules. If either of these two are Activated, then the issue occurs. If they are both deactivated the issue goes away.

    Thank you for your assistance thus far. Much appreciated.

    I have further narrowed it down to being an issue with the featured image. Where I noted above that the issue did not occur when I created an identical post with an image previously used. Once I set the featured image for that post; the issue will occur. (As long as the “Publicize” and “Sharing” modules are activated, if deactivated the issue resolves)

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Malfunction with PHP upgrade’ is closed to new replies.