Support » Installation » Making WP & xampp friendly

Making WP & xampp friendly

  • I (WP, MySQL, & xampp newbie) am having an issue with WP and xampplite. I successfully installed both apps and got WP running in no time at all. But i forgot my random password OOPPPS. so i deleated both installs and tried to reinstall them both. I got xampp up and running but when i tried using WP it will not let me past the initial blog creation page stating that i have already installed WP.

    I have erased and redownloaded both apps, and even tried to use them on another machine with the same problem. does anyone have any experience with getting WP and xampp to work together?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Did you drop the WordPress tables from your database before reinstalling?


    also, the WP-install.php page has all kinds of funky words (code?) exposed above and below the login fields

    Are they error messages, or does it look like source code?

    If the latter, then likely PHP is not enabled and running on the server.

    here is what appears on the top of the page:

    “wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn’t work for all server setups. The safest way is to manually create the file.”); require_once(‘../wp-config.php’); require_once(‘./upgrade-functions.php’); $guessurl = str_replace(‘/wp-admin/install.php?step=2’, ”, ‘http://’ . $_SERVER[‘HTTP_HOST’] . dirname($_SERVER[‘PHP_SELF’]) ); if (isset($_GET[‘step’])) $step = $_GET[‘step’]; else $step = 0; ?>

    hide_errors(); $installed = $wpdb->get_results(“SELECT * FROM $wpdb->users”); if ($installed) die(__(‘
    Already Installed
    You appear to have already installed WordPress. To reinstall please clear your old database tables first.”

    i do have a wp-config file setup. and i have cleared the old database. i am really green at php and mysql.

    thanks for the help

    That looks like you either do not have the php running OR you have put the files outside of the htdocs directory

    it appears that i have php running. i have created a page of screenshots for people to see and proabably tell me about a blairing mistake.

    http://portfolio.iu.edu/roconnel/xampp.jpg (shots of xampp and wp-config)
    http://portfolio.iu.edu/roconnel/WordPress_›_Installation.htm (this is the funky page that i get)

    I don’t know if WP still has “problems” with PHP 5, but at least I changed to PHP4-something on XAMPP (it used PHP5 as a default). There’s a script for the change somewhere. I’m sure XAMPP’s instructions say where it is.

    Don’t know if that’s an answer to your problem but just a thought.

    Btw, you didn’t answer Podz’s question about the files being in htdocs. Could that be your problem?

    the files are in htdocs and not in a subfolder or anything.

    would “php4ts.dll in F:\xampplite\install” be teh file to convert to php4?

    Actually, there should be a “PHP Switch” in the XAMPP (or apachefriends) menu. It runs a file called php-switch.bat

    I have being running XAMPP with WP and php 5 for about 4 months with no problems.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Making WP & xampp friendly’ is closed to new replies.