Support » Networking WordPress » Making WordPress Multisite work with PHP 7.x

  • hey WP experts. I unfortunately installed a wordpress multisite on our old server running php 5.4. Even tho we moved the installation to a new server with php 7.x now, the WP is still stuck on php5, does not detect the php7. What would be the easiest way to get this running with php7. I do have an idea, but please correct me if I’m wrong:

    I can install a fresh copy of multisite on the new server in the same domain name. point the installation back to the old db, and copy all the files in the wp-content folder over to the new install. I hope it can be as simple as that but probably not lol.

    Thank you all!

    • This topic was modified 4 months, 3 weeks ago by James Huff. Reason: moved to Networking WordPress forum
Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey there,

    if the domain is exactly the same it should work like you thought:

    1) copy all wp-contents to the fresh install
    2) point to the old db using wp-config

    Best,
    Seb

    The WordPress doesn’t choose the PHP version… your hosting configuration decides that!

    Maybe your webhost can help you sort this problem out.

    We run our own servers, they are all running php7 because I set them up myself. Its common knowledge you’d have to reinstall wordpress if it was installed in php5 enviroment.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.