• I only have this plugin activated when I am NOT online as it is making WordPress extremely slow. At first I thought it was my internet connection or browser, but then I noticed how my homepage was acting normal and that I only had issues when using wordpress. After turning off the plugins one by one I finally reached this plugin in the bottom and wordpress got soooo much faster. Before it could take more than 5 minutes to load a page, now it takes less that 5 seconds. It is beyond horrible that such a popular plugin can damage your site performance so badly and they dont seem to try to fix it as people are complaining about it a lot. All in all it is a really bad plugin with good intentions.

Viewing 1 replies (of 1 total)
  • Plugin Support Jerlyn


    Thanks for the feedback @japanoholic !

    We are sorry to hear that you were having performance issues with our plugin. We would like to clarify that Yoast SEO does not directly cause a site to be slow. It can occur for various reasons, such as a conflict with other plugins or themes. Site speed depends on a lot of factors. Kindly check the following article How to speed up your site where we have added tips for increasing site speed.

    To investigate the issue, you may check the following:

    1. Please make sure the website is meeting the necessary plugin requirements and the rest of your plugins and themes are up-to-date
    2. Are you using visual page builders or editors that replace the default WordPress editor?
    3. Does it resolve the issue if you go to WordPress Yoast SEO > Settings > General > Site features and disable the Insights feature?
    4. Could you check if you’ve already completed the SEO Data Optimization process under Yoast SEO Tools?
    5. If you go to Yoast SEO > Settings and disable the Text Link CounterInsights, and Link Suggestions, does the issue still happen?

    If the issue persists, you may ask for additional assistance from our Support team by creating a new topic here. We would be happy to help!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this review.