Support » Fixing WordPress » making wordpress blog a home page

  • Resolved juliatrops

    (@juliatrops)


    Hi there, I am at my wits end. How can I make a wordpress blog my home page? I am hosted by netfirms.

    If I do a pointer to the directory, then every other reference I have out there appears to be blocked…

    Is there a switch that I can mark that will make it the home page without affecting everything else in the directories?

    Thank you so much for your help!

Viewing 15 replies - 1 through 15 (of 20 total)
  • What is your current home page? Is WordPress hosted in a different directory?

    Oh, with netfirms you’ll have troubles if you used their “automatic” install (which sux, BTW :).

    Hi there, the current homepage is http://www.juliatrops.com, and the wordpress installation is in www/juliatrops/nfblog directory.

    Yes, I used their automatic install.

    It works great, if I use a pointer for the website to point to the actual directory… but then all my other references are cut off… I have an ebay store which calls images from my website. Is there anything I can do –

    What if I reinstall and then copy my current files for this particular website over to it.. actually, all the sites existenceinthedream.com, lifedeathbecoming.com and mozarts-strings.com are all the same – so that wouldnt be a huge problem to do…

    is that a better idea?

    what else should I look out for – I have only done all this in the past week, so no real comments have happened to make sure all is working well… if any of you have time, I would really truly appreciate some feedback.

    1. Your site wants me to download it 🙂
    Is it a new install or an upgrade?
    2. Find a better host.
    3. Or, at least get rid of that install in “nfblog” and do a manual install in your root. (For some unknown reason netfirms has this stupid, useless, idiotic idea to put every blog a directory called “nfblog”…)
    4. You can try this
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    but if it doesn’t work on your server, don’t blame me!

    hi Moshu…
    thank you for your response..

    answers:
    – new install, not upgrade. I just switched to netfirms because of the store ability they have. Thought I would try them for a year.

    can I choose to do a manual install in the root?
    I will check out the codex ref you gave..

    So guess you are saying I should just reinstall in the root…?

    Thank you!

    For manual install see this:
    http://codex.wordpress.org/Getting_Started_with_WordPress
    The previous links was for the case IF you want to leave your WP install in a subdir, but have the blog to show up in root.

    sorry, back again, just read the codex –

    does this mean that when a person goes to http://www.juliatrops.com that the homepage will open automatically?

    hi again…
    I am reading the giving wordpress its own directory..
    I dont understand step 3 about the public_html…

    Do I need to create that directory under www/juliatrops/? I dont see any other public_html directory anywhere in filezilla…

    Oh, that’s server dependent, sorry. In your case is www/
    On other servers it might be public_html or htdocs…

    Chip Bennett

    (@chipbennett)

    Theme Review Admin

    I have my blog installed in http://www.chipbennett.net/wordpress/

    My homepage is http://www.chipbennett.net

    My root index page is index.php, which contains only a php require call to the wordpress index page:


    <?php require("http://www.chipbennett.net/wordpress/index.php"); ?>

    If you’re having problems with relative links, try using absolute links instead?

    Man, your main page is way too long… hardly been able to wait that long to take a look at it.
    And in your right sidebar you have the same ad about ten times.

    okay…

    so I did it.

    I couldnt find the .htaccess page. I know I have it enabled in netfirms.

    Also have the rss plugin (which was fabulous!!) and got these errors when I opened my page, so I deactivated it, and it seems fine..

    Warning: fopen(./wp-content/plugins/lastsubmit.txt): failed to open stream: No such file or directory in /mnt/web_e/d31/s01/b0267acb/www/wordpress/wp-content/plugins/rssautosubmit.php on line 44

    Warning: fgets(): supplied argument is not a valid stream resource in /mnt/web_e/d31/s01/b0267acb/www/wordpress/wp-content/plugins/rssautosubmit.php on line 45

    Warning: fseek(): supplied argument is not a valid stream resource in /mnt/web_e/d31/s01/b0267acb/www/wordpress/wp-content/plugins/rssautosubmit.php on line 63

    Warning: fwrite(): supplied argument is not a valid stream resource in /mnt/web_e/d31/s01/b0267acb/www/wordpress/wp-content/plugins/rssautosubmit.php on line 64

    Can someone please go to http://www.juliatrops.com and see if it is okay??

    THANK YOU!!!!

    Chip Bennett

    (@chipbennett)

    Theme Review Admin

    The “same ad” is Amazon deciding to put a generic ad in place of the book links I have; not sure why they do that.

    Other than that, the posts took less than a second to load. The SiteMeter and Ecosystem scripts hang up the pageload a bit, though.

    Anyway, is that the kind of solution s/he’s looking for, or am I way off?

    It’s OK 🙂 glad it worked out.

    greetings from Winterpeg…

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘making wordpress blog a home page’ is closed to new replies.