WordPress.org

Support

Support » Themes and Templates » Making Themes compatible for 2.0.x and 2.1.x at same Time

Making Themes compatible for 2.0.x and 2.1.x at same Time

  • Hi,

    is it possible to make the same Theme comatible for 2.0.x and 2.1.x with one version? I think about something like a Loop in a file:

    if wp 2.0.x {... code for blogroll}
    if wp 2.1.x {... code for blogroll}

    because its pain in the neck to make for every theme two versions (one for wp 2.0 and one for 2.1).

    greetings

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thx for so many answers :-). But i found the solution:

    '<?php if (($wp_version < "2.1")) {
    wp_list_cats('sort_column=name&optioncount=1');
    }
    if (($wp_version >= "2.1")) {
    wp_list_categories('sort_column=name&show_count=1&title_li');
    } ?>'

    ooo..cool! Good idea 🙂

    First time I’ve seen this thread.

    Probably could use the function call if_function_exists(‘function_name’) as well. I think that’s it.

    @drmike,

    thank you for the answer. it works.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Making Themes compatible for 2.0.x and 2.1.x at same Time’ is closed to new replies.
Skip to toolbar