Support » Themes and Templates » Making SubMenu item the primeri item in the menu

  • Hi!

    What’s the problem?

    Here: currently working on this
    If you click on “Teenused” it will make every item there active (orange) and therefore silly to look at.

    Now there are two solutions:

    1. Making one subpage the primary page in the menu. For example: If you click “Teenused” on main menu it will automatically direct you to “Elektritööd”: Elektritööd And then it skips the part where you will have to think of some text under “Teenused”. Same as the function to solve “Home page” problem with setting a static page for it.

    2. Adding a piece of code that will make every item in submenu inactive (grey) until I click on it and with the possibility to set one of the subpages to a static (home page) for the main page.

    Example: Page A has subpages Aa, Ab, Ac. Home page is set static Ac so that clicking on HOME (“Esileht” on my example) will direct you to Ac.

    Now I have pages A, B, C and D and all of them have subpages from a to d for example. I want to be able to set my chosen page the static primary page of the master pages. Like this: Bc will be the static page for B which means that if I click on B it will show me immediately Bc.

    Did I explan myself correctly now?

    Ask any if needed. I think this problem might interest many of WordPress users.

    * WP 2.9.1
    * corporate-theme-v2

Viewing 2 replies - 1 through 2 (of 2 total)
  • 3rd option. Try resetting the colour of the child (dropdown) links to dark grey when the parent link has focus using CSS. Your current :hover and :active CSS is far too generic.

    I think I know what you mean but I am no css code writer myself.

    AXB AS menu link
    Currently Active page is “AXB AS” When you now hover over AXB every item is active… I don’t want that. How can I change it? Maybe a few line of codes to put to the CSS?

    I have that kind of a code in CSS which might be a part of the problem:

    #nav a:hover, #nav a:active, .current_page_item	a, #home .on {
    	background:url( top center repeat-x; /*mover over*/

    And this leads me to another problem which is that an Active menu is not actualy present- theres only hover.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Making SubMenu item the primeri item in the menu’ is closed to new replies.