Support » Plugin: WooCommerce Sequential Order Numbers » Making other plugins compatible to WC Sequential Order Numbers

  • Resolved Jason Wong

    (@eljkmw)



    I’m glad to come across this plugin, but somewhat afraid to integrate it into my WC website. This is because I’ve some other WC-related plugins that might not be compatible to your plugin, and replacing every $order->id with $order->get_order_number() might not be the answer. I realise that some of these plugins may require $order->id for some processing purpose. And this could be especially true for payment gateway plugins. I cannot simply replace all $order->id, and hope that all will be running well.

    What will you suggest to curb with this problem? Perhaps a snippet that can resolve this, instead of hacking into other plugins’ source code to make the replacements.

    Please advise. Thank you.

    https://wordpress.org/plugins/woocommerce-sequential-order-numbers/

Viewing 1 replies (of 1 total)
  • Plugin Author SkyVerge

    (@skyverge)

    Hey Jason, apologies on the delay here! This thread looks like it slipped through the cracks on our end.

    I’m afraid that a snippet won’t be able to anything here, as changes in the payment gateway (or other) plugin need to be made to add full support. Without them using the order number instead of using the order ID directly, there’s not much our plugin can do outside of this / can’t filter anything via a snippet, as it acts solely on the order number.

    We’ve had good success with asking other developers to support SON and the pro version, so I’d recommend sending our notes on compatibility to the plugin author, as there’s a chance they will update the plugin itself with these changes instead of you needing to make them manually.

    Thanks! -Beka

Viewing 1 replies (of 1 total)
  • The topic ‘Making other plugins compatible to WC Sequential Order Numbers’ is closed to new replies.