Support » Theme: Blackoot Lite » Making Header image and featured image disappear on small platforms

  • Resolved sifinley

    (@sifinley)



    I have been directed to this page for advice on my blackoot theme. I basically want to make my header image and featured image on the home page disappear when it is viewed on smart phones and smaller tablets. I have been advised that it has something to do with Media query. Can anyone help?

    My website is simonfinley.net

    thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Theme Author Iceable

    (@iceable)

    Sure, a media query is indeed the key for this since it can limit CSS so it only applies for some screen sizes.

    This will do the trick for the header image:

    @media only screen and (max-width: 767px) {
    #header-image { display: none; }
    }

    In plain English this CSS means: “Do not display the header image if the screen is not larger than 767px” (that’s basically tablets and smaller devices).

    Looking at your homepage I wasn’t sure about the “featured image” you mentioned, so please let me know if I misunderstood and I’ll help you adjust this code.

    The easiest way to add this CSS to your site is to install a custom css plugin (like this one for example: https://wordpress.org/plugins/simple-custom-css/ )
    Once installed you’ll find it in Appearance > Custom CSS, and there you can paste this code.

    Worked like a treat thanks!

    The featured image I was talking about is the ‘He is a Dragon’ advert above the RECENT WORK section. I want this to disappear as the text is too small on small phones. Or is there an easy way to have this image replaced with another one when the browser goes below 767px? That would be a better alternative.

    Thanks

    Theme Author Iceable

    (@iceable)

    Hi again, this image was added directly to the content and it doesn’t have a specific class so we can’t target it precisely with CSS without altering other images elsewhere on the site. However you can easily add a custom class to it.

    An easy trick to “replace” it on mobile would be to add both images into the content, and use media queries to hide one on desktop and hide the other one on mobile.

    So first edit your page content and add the image you want to use on mobile just after the original one.

    If you are using the “Visual” editor, click the first image (the one for desktop) and click the “edit” icon.
    In the “Image details” window that pops up, click “advanced settings” and you’ll see an “Image CSS class” field. Enter hideonmobile into this field.
    Repeat with the second image, and give it the hideondesktop CSS class.

    (You can also use the “text” editor and add these classes to both images directly into the code if you prefer to deal with raw HTML.)

    Then add this to your Custom CSS:

    @media only screen and (max-width: 767px) {
    .hideonmobile { display: none; }
    }
    
    @media only screen and (min-width: 768px) {
    .hideondesktop { display: none; }
    }

    And there you have it!

    Thanks for the reply. I have just tried that but it doesn’t seem to work. Both images display on desktop and mobile rather than one replacing the other. I’ve definitely added the right css class field to each image and copy and pasted the media query code you provided but it doesn’t do what it is suppose to

    Theme Author Iceable

    (@iceable)

    Hi, I just had a look at your site and found that some default CSS was overriding this code, making the image(s) show anyway.

    If you add “!important” to each CSS statement it prevent this issue. Please change the above code to:

    @media only screen and (max-width: 767px) {
    .hideonmobile { display: none !important; }
    }
    
    @media only screen and (min-width: 768px) {
    .hideondesktop { display: none !important; }
    }

    and this time it should work as expected 🙂

    Works perfect! Thanks you again for the help 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Making Header image and featured image disappear on small platforms’ is closed to new replies.