Support » Plugin: Site Reviews » Makes My website Extremely Slow

  • Resolved paulbc0

    (@paulbc0)


    Hi,

    I really like your plugin and I have been using it for quite a while. However, now I have a good amount of reviews the plugin seems to be making my website extremely slow. When I have tested my site and analysed other plugins in case they were the cause etc I was able to narrow the speed issue down to your plugin.

    Also, testing with Pingdom tools on occasion the page showing my reviews can take up to 29 seconds to load. The best I have got it to is just over 5 seconds. This is even with using a caching plugin.

    Can you offer any advise on how to remove this slow speed issue with your plugin?

    Many thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Gemini Labs

    (@geminilabs)

    Hi @paulbc0,

    The first thing to do to track down the cause of this issue is to install the Debug Bar and Debug Bar Slow Actions plugins:

    https://wordpress.org/plugins/debug-bar/
    https://wordpress.org/plugins/debug-bar-slow-actions/

    Once installed and activated, you will see a “Debug” link in your admin bar.

    The next thing is to enable the “Show Toolbar when viewing site” in your user profile.

    Finally, refresh the page on your website that is slow and once it has loaded, click the “Debug” link on the admin bar and select “Slow Actions”. This will show you all the WordPress hooks that have been triggered on page load sorted by slowest to fastest.

    Any Action of Filter that has taken longer than 100ms total to run, please expand it and take a screenshot. Once you have done this, please send both the screenshots you took along with the “Site Reviews > Get Help > System Info > Download system info” report to: site-reviews[at]geminilabs[dot]io

    Thanks

    Plugin Author Gemini Labs

    (@geminilabs)

    Another thing to note:

    The pages on your website with reviews are NOT being processed by your Comet Cache plugin, unlike your other pages. This could make it appear that the plugin is causing your page to slow down when really the cause might be that it is just not being cached like your other pages are.

    The source code of those pages show the following notice:

    Comet Cache is NOT caching this page, because the current page contains _wpnonce or akismet_comment_nonce. Your current configuration states that pages with dynamic *nonce* values in the markup should not be cached. See http://wsharks.com/1O1Kudy for further details.

    And loading a paged result of reviews (i.e. https://your-website.com/reviews/?reviews-page=2) shows:

    Comet Cache is NOT caching this page, because $_GET contains query string data. The current configuration says NOT to cache GET requests with a query string.

    paulbc0

    (@paulbc0)

    Hi,

    Many thanks for your reply. I will look to do this now and get back to you.

    Cheers

    Plugin Author Gemini Labs

    (@geminilabs)

    To solve the first caching issue above, please read the “Globally (dangerous)” and “WordPress Nonce Lifetime” sections at http://wsharks.com/1O1Kudy to learn how to enable the cache for pages with nonces and to set the expiration for pages with nonces to 1 day.

    paulbc0

    (@paulbc0)

    Hi,

    I am currently going through the details as described in your message earlier and there are many ‘Action or Filter’ items over 100ms with quite a few almost at 1,000ms and a few almost at 2,000ms. I am currently working my way through taking screenshots.

    However, following on from your second message regarding the caching of that page are you able to offer any advice as to why you would think that particular page would have those values that stop the page from being cached? I can’t see or think of a reason why it should. I can see why a key part of the shopping experience would require it via woocommerce such as add to cart or checkout but not sure why a reviews page would?

    Many thanks.

    Plugin Author Gemini Labs

    (@geminilabs)

    Nonces are generally used in forms to protect against certain types of misuse. Site Reviews uses a nonce in its submission form.

    Plugin Author Gemini Labs

    (@geminilabs)

    Another thing to check using the Debug Bar plugin is for slow Database Queries.

    You do this by reloading a page on your website that is slow, then clicking the “Debug” link on the admin bar and choosing “Queries”. This will show you all the database queries that were triggered on the page. Underneath each query in a light grey box on the right side you can see how long it took in milliseconds to perform the query.

    Any query that takes more than 1-3 ms is contributing to the slowdown of your page.

    Please take screenshots of any database queries (both the query and the light grey box underneath it that shows the time in ms) that are taking more than 2 ms to complete and send them to me to evaluate.

    paulbc0

    (@paulbc0)

    Ah right, thanks for that help. However, I have now come across something that seems to dramatically affect the load time of that page.

    When I installed those toolbar plugins you suggested and tested the reviews page it has come out with a total actions execution time of over 16200ms and on occasion even reached 20000ms+.

    Out of curiosity, I changed my settings to ‘not use’ the invisible reCaptcha and now the total actions executions time averages just under 2400ms which is a huge improvement (85%+ quicker) and the page can be visibly noticed that it loads quicker.

    I would prefer to have the invisible reCaptcha facility but I am thinking this is the cause of the slow speed on that page. Is there a way to use the standard reCaptcha V2 as on other websites I have this does not seem to cause any slowing of the site.

    Many thanks.

    Plugin Author Gemini Labs

    (@geminilabs)

    It’s unclear to me how that would be the cause, unless you are experiencing conflicts with another plugin that is also using recaptcha.

    When recaptcha is enabled it does three things:

    1. Adds a DIV container to the submission form where the recaptcha will load.
    2. Adds the recaptcha script from google with the async attribute to prevent blocking the page rendering.
    3. Once the recaptcha script from google has loaded, it automatically renders the recaptcha in the DIV created in step 1.

    paulbc0

    (@paulbc0)

    Hi,

    I agree. I was surprised that this improved the speed of the page. When I re-activate the reCPATCHA once again the page slows down. For the time being, I have disabled the reCAPTCHA facility whilst I continue to investigate and take those screenshots.

    Many thanks

    Plugin Author Gemini Labs

    (@geminilabs)

    It’s been a week and I have not heard back or received an email from you.

    I will wait a few more days before closing this issue.

    Thanks

    Plugin Author Gemini Labs

    (@geminilabs)

    @paulbc0 I would like to invite you to try out the unreleased (but stable) v3.0 of Site Reviews. It has been rebuilt from the ground up with performance in mind. You should see a noticeable speed increase with even thousands of reviews.

    Instructions here: https://pastebin.com/raw/Mgr28aJs

    v3.0 should solve the speed issues that you were experiencing in v2.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Makes My website Extremely Slow’ is closed to new replies.