Support » Everything else WordPress » Make the template compatible with the latest version of WordPress

  • Hello good time
    How can I adapt an old WordPress template to the latest version of WordPress?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Not that much has changed for themes lately, although it might be a lot if it’s really old.
    You can read the Theme Developer Handbook, and reference the functions in the Code Reference, though.
    Try running the theme on a test site (you can use a sandbox at https://wpsandbox.net/ if you need a quick one), and turn on DEBUG to see what errors you get.

    Thread Starter moinds

    (@moinds)

    The template works for WordPress 4.9.16
    I am updating to WordPress 5.6, the template is incomplete
    I activated the debug but it only gave an error
    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; acera_theme_options has a deprecated constructor in \ wp-content \ themes \ Tinyz \ acera-options \ generate-options.php on line 8

    That is not a WP version problem. That is a PHP version problem. You can read about PHP class constructors on the PHP site.
    The deprecation is only a warning, so there must be something else failing if your “template is incomplete”. Check the error_log on the server.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.