Support » Plugin: OMGF | Host Google Fonts Locally » Make sure the dns-prefetch is removed, too

  • Resolved Martin Braun

    (@martinbraun)


    The plugin’s “Remove Google Fonts” feature is dope, however it’s not perfect. I was able to spot one last link element to Google Fonts after using it:

    <link rel="dns-prefetch" href="//fonts.googleapis.com">

    It would be nice if this would be deleted, or do I miss something here?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter Martin Braun

    (@martinbraun)

    Ok nvm,

    I installed a plugin to get rid of the DNS prefetch entries, that should be fine the way it is.

    Thread Starter Martin Braun

    (@martinbraun)

    Closing this.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    That’s a dns-prefetch entry. It’s not loading an actual font.

    But you make a good point. I have to decide now, whether this falls in the scope of OMGF.

    Thanks for notifying me!

    Hi,

    First thanks for the great plugin!
    Any update on this topic?
    After removing Google Fonts via OMGF I still had two lines I didn’t like to see (although these might not cause and GDPR problem as you say):

    <link rel='dns-prefetch' href='//fonts.googleapis.com' />
    <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />

    To remove the first one I had to completely disable Google Fonts in my Flatsome theme which is not that nice, as this option must stay enabled to be able to configure the other font settings for the theme. Maybe it would be nice if OMGF can disable the line for me.

    To remove the second line I had to disable “Optimize Google Fonts” in the WP Rocket plugin I am using.

    Hope this information helps.

    Anguel

    • This reply was modified 10 months, 1 week ago by iAnguel.
    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Hi Anguel,

    I forgot to update the entry here. The thing is, that some plugins and themes decide to add this entry, but there’s no ‘clean’ way to do that. So, there’s also not a clean way to remove it!

    As soon as I find one, I’ll circle back to this topic and implement it. But at this point there isn’t.

    Many thanks, Daan!

    Best regards,

    Anguel

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Make sure the dns-prefetch is removed, too’ is closed to new replies.