Support » Plugin: Post SMTP Mailer/Email Log » Show different e-mail address to recipients

  • Resolved gareth94

    (@atebol)


    Hello,
    I was wondering if anyone could help me. I’m using the Post SMTP plugin to send mail from my WordPress site. However, I’d like the recipients of my e-mails to see a different e-mail address than what I’m using to send the e-mails. I can’t figure out how to do this in the settings. I’ve put the e-mail I want people to see in the Envelope-From Email Address field but that doesn’t work (the e-mails still show as being from the sending e-mail/account). I’ve also tried changing the Email Address field under Messagesettings but that results in the e-mails not sending at all πŸ™
    My e-mails all belong to the same domain (Office 365) so this should help things?
    I wonder if anyone else has come across this issue before?

    • This topic was modified 2 months ago by gareth94.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Support Tim

    (@tneville)

    Hi @atebol,

    Are you using Authenticated SMTP, or the Office 365 API Extension?

    Kind Regards,
    Tim

    Thread Starter gareth94

    (@atebol)

    Thank you @tneville. Ummm I’m not sure… I’ve just set everything up using this plugin? I haven’t installed any other extensions… sorry if this doesn’t help much!?

    • This reply was modified 2 months ago by gareth94.
    Plugin Support Tim

    (@tneville)

    Hi @atebol,

    No problem. It sounds like you are using Authenticated SMTP. Perhaps you could paste a copy of your diagnostics log in your next reply? That would help.

    In this case, you need to authenticate as the user you want to send as.

    Kind Regards,
    Tim

    Thread Starter gareth94

    (@atebol)

    Yes I’m pretty sure you’re right @tneville. I’ve included below the diagnostics log I obtained from the plugin. Hope it helps?

    Mailer: postsmtp
    HostName: atebol.com
    cURL Version: 7.35.0
    OpenSSL Version: OpenSSL/1.0.1f
    OS: Linux blue1080.server-cp.com 3.13.0-83-generic #127-Ubuntu SMP Fri Mar 11 00:25:37 UTC 2016 x86_64
    PHP: Linux 7.3.5 C
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=No, zlib_encode=Yes
    WordPress: 5.7.1 en_US UTF-8
    WordPress Theme: Divi
    WordPress Plugins: WPML Multilingual CMS, Yoast SEO Multilingual, Advanced Custom Fields Multilingual, FiboSearch - AJAX Search for WooCommerce, Contact Form 7 Conditional Fields, Contact Form 7 Styler for Divi, Code Snippets, Contact Form 7 Multilingual, Contact Form 7, Cookie Notice & Compliance for GDPR / CCPA, Divi Mega Menu, Duplicate Page, ELEX WooCommerce Bulk Edit Products, Prices & Attributes (Basic), Smash Balloon Instagram Feed, Kadence WooCommerce Email Designer, LitExtension Customer Password Plugin, LitExtension: Shopping Carts to WooCommerce, WooCommerce Load More Products, Mailchimp for WooCommerce, Multiple external product URLs for WooCommerce, Post SMTP, Preorders for WooCommerce, Product/Review CSV Import Export, Regenerate Thumbnails, Supreme Modules Lite - Divi Theme, Extra Theme and Divi Builder, Tawk.to Live Chat, TI WooCommerce Wishlist, Toolset Types, Cart All In One For WooCommerce, Woocommerce delete product images, Braintree For WooCommerce, SKU Label Changer For WooCommerce, Advanced AJAX Product Filters for WooCommerce, WooCommerce Multilingual, WooCommerce Shipping & Tax, WooCommerce, Wow Carousel for Divi Lite, WP Add Mime Types, WP All Import Pro, WP Rocket, WP Sitemap Page, Smart Image Resize PRO, WP All Import - WooCommerce Add-On Pro, Woo Coupons Pay for Shipping, WPForms Lite, WPML All Import, WPML CMS Nav, MailChimp for WordPress Multilingual, WPML Media, WPML Sticky Links, WPML String Translation, WPML Translation Management, WPForms Multilingual, WPvivid Backup Plugin
    WordPress wp_mail Owner: /var/www/vhosts/atebol.com/atebol_corporate/wp-content/plugins/post-smtp/Postman/PostmanWpMailBinder.php
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email, PostsmtpMailer->get_mail_args
    WordPress phpmailer_init Action(s): wpcf7_phpmailer_init, WC_Email_New_Order->handle_multipart, WC_Email_Cancelled_Order->handle_multipart, WC_Email_Failed_Order->handle_multipart, WC_Email_Customer_On_Hold_Order->handle_multipart, WC_Email_Customer_Processing_Order->handle_multipart, WC_Email_Customer_Completed_Order->handle_multipart, WC_Email_Customer_Refunded_Order->handle_multipart, WC_Email_Customer_Invoice->handle_multipart, WC_Email_Customer_Note->handle_multipart, WC_Email_Customer_Reset_Password->handle_multipart, WC_Email_Customer_New_Account->handle_multipart, WC_Email_New_Pre_Order->handle_multipart, WC_Email_New_Pre_Order->handle_multipart, PostsmtpMailer->phpmailer_smtp_init
    Postman: 2.0.22
    Postman Sender Domain (Envelope|Message): atebol.com | atebol.com
    Postman Prevent Message Sender Override (Email|Name): Yes | Yes
    Postman Active Transport: SMTP (smtp:tls:login://smtp.office365.com:587)
    Postman Active Transport Status (Ready|Connected): Yes | Yes
    Postman Deliveries (Success|Fail): 87 | 8
    Plugin Support Tim

    (@tneville)

    Hi @atebol,

    Yes, that does help! It is indeed Authenticated SMTP. As you’re running WooCommerce I would stick with this rather than the API extension, there are a few known issues with that in case you discover it.

    So, just to clarify. You are sending as alice@example.com but you want mail to be sent from bob@example.com? If that’s the case, why can you not authenticate as bob@example.com?

    Kind Regards,
    Tim

    Thread Starter gareth94

    (@atebol)

    Thanks @tneville

    Unfortunately I can’t authenticate as bob@example.com as it is a shared mailbox (and has a 2-step security verification which would interfere with the set-up) on our Office 365 organisation account (and we would have to pay extra a month to make the account work as needed). Or at least this is what I’ve understood from our IT company…

    Our old website sends mail from alice@example.com but has a sending alias/email of bob@example.com which displays correctly on our customers confirmation e-mails. However this was on Magento 1.9….

    • This reply was modified 2 months ago by gareth94.
    • This reply was modified 2 months ago by gareth94.
    Plugin Support Tim

    (@tneville)

    Hi @atebol,

    Your IT company is correct, but as far as I am aware you can’t send from a Shared Mailbox in 365. If you can, tell me more!! πŸ˜€

    You might want to look into something like Amazon SES, Mailgun, SendGrid, or some other bulk SMTP provider. I’m afraid I can’t recommend you one, though I have used both Amazon SES and Mailgun successfully. It does have a cost and a bit of fiddly DNS work though.

    As a final solution, which doesn’t involve much work, would setting a ‘reply to’ header on your outgoing mail work? You can do that in Post SMTP and almost all mail clients will honour it.

    Does that help?

    Kind Regards,
    Tim

    Thread Starter gareth94

    (@atebol)

    Ah right ok I see… the strange thing is though… we were able to set-up an alias e-mail on our Magento to send from a shared mailbox! Bit puzzled to how that worked really….!

    Www the ‘reply to’ header you mentioned sounds interesting! Only thing is, would it still show the incorrect e-mail account as the ‘From Address’ on the client side?

    Plugin Support Tim

    (@tneville)

    Hi @atebol,

    My previous comment was perhaps a bit misleading, you can sort of send as a shared mailbox. You have to authenticate as a “real” user (e.g. alice@example.com and then set your sender name to bob@example.com). Sorry for the confusion there.

    Having now just written that out, that’s basically the set up you described in your original post. (It’s been a long day!)

    I’ll do some testing with my own account tomorrow and see if I can produce this. I presume you’re getting the problem even on the Post SMTP test mails with the set up mentioned in your original post?

    I’m also in the UK – it looks like we are both night owls, though I’m trying not to be! πŸ˜€

    Catch up with you tomorrow (or asap)!

    Kind Regards,
    Tim

    Thread Starter gareth94

    (@atebol)

    Ah thanks so much @tneville for your help with this. Yes it seems we’re both night owls! haha

    I’d be so grateful for any testing you could do! Yes, like you said, if I do my preferred set-up in the Post SMTP settings, I get an error when sending a test e-mail (or even trying it live from the frontend)

    Thanks again Tim!

    Plugin Support Tim

    (@tneville)

    Hi @atebol,

    Just tested your set up and it works okay for me. Just to clarify the settings:

    • Account Tab – Envelope-From Email Address – This should be your shared mailbox email.
    • Account Tab – Username – This should be your “real” licensed user. They must have access to the shared mailbox, naturally.
    • Message Tab – Email Address – This should be your shared mailbox email.

    If that still doesn’t work, please try ticking the ‘Prevent plugins and themes from changing this’ for the email address in the ‘Message’ tab.

    Good luck, and let us know how you get on. πŸ™‚

    Kind Regards,
    Tim

    Thread Starter gareth94

    (@atebol)

    Thank you for your time and efforts with this @tneville!

    Unfortunately my Account tab settings are exactly as you described (and still doesn’t work). When I put the shared mailbox in the Email field (in the Message tab), I get the following error when doing a test email:

    5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message. 0.35250:0A00E386, 1.36674:01000000, 1.61250:00000000, 1.45378:02000000, 1.44866:00000000, 1.36674:7A000000, 1.61250:00000000, 1.45378:05000000, 1.44866:00140000, 1.36674:0A000000, 1.61250:00000000, 1.45378:16000000, 1.44866:99290000, 1.36674:0E000000, 1.61250:00000000, 1.45378:B2290000, 1.44866:E2010000, 16.55847:44160000, 17.43559:0000000030020000000000000A00000000000000, 20.52176:140FCA8F1800F01F0A00C530, 20.50032:140FCA8F8817F01F07000000, 0.35180:1F000130, 255.23226:A72C0000, 255.27962:7A000000, 255.27962:0A000000, 255.27962:0E000000, 255.31418:21000000, 0.35250:1F001336, 1.36674:0A000000, 1.61250:00000000, 1.45378:02000000, 1.44866:4C000000, 1.36674:32000000, 1.61250:00000000, 1.45378:51000000, 1.44866:01000000, 16.55847:B8000000, 17.43559:00000000B0030000000000000100000000000000, 20.52176:140FCA8F180010106C000000, 20.50032:140

    Plugin Author yehudah

    (@yehudah)

    Inside the shared mailbox managment go to
    Mail Tab -> Mange Email Apps -> Verify that everything is checked

    https://i.stack.imgur.com/lXoQJ.png

    Plugin Support Tim

    (@tneville)

    Hi @atebol,

    Also – just checking that the user you are authenticating as (the “real” user) has full permission and ability to send as the shared mailbox? Can you send as the shared mailbox from that user in other mail apps like Thunderbird?

    Kind Regards,
    Tim

    Plugin Support Tim

    (@tneville)

    Hi @atebol,

    We haven’t heard from you in a while, so I’ll mark this thread as resolved. If you have any further questions please feel free to open a new thread, and link to this one.

    Kind Regards,
    Tim

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.