Support » Plugin: Scroll Back To Top » Make plugin validate for accessibility

  • Hi Joe I am working with a theme that is geared towards web accessibility and using a web accessibility checker called achecker.ca/checker/ , this element is flagged as an error with your plugin (which is awesome by the way!):

    <i class="fa fa-2x fa-arrow-up"></i>

    the suggested solution is to:
    Replace your i elements with em or strong.

    think we could get that applied as it seems to be it could be a pretty quick fix (at least to me but I am not a programmer)

    thanks!

    https://wordpress.org/plugins/scroll-back-to-top/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author joesexton00

    (@joesexton00)

    Yes it is possible currently, though it will require adding some code to your theme’s functions.php file. There is a filter for the button markup that allows you to alter the markup however you need to. For example, to change the <i> to a <em> add the following to your theme’s functions.php file.

    add_filter( 'sbtt_button_markup', 'my_sbtt_filter' );
    function my_sbtt_filter($button_markup) {
    
    	$button_markup = str_replace('<i ', '<em ', $button_markup);
    	$button_markup = str_replace('</i>', '</em>', $button_markup);
    
    	return $button_markup;
    }

    thanks, that worked! something you may want to change though on your next update if its neither here nor there what is used?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Make plugin validate for accessibility’ is closed to new replies.