Support » Fixing WordPress » Make “Link to media file” point to full-size image?

  • Using the Gutenberg Gallery Block in WordPress 5.0.3, in the Block-settings choosing “Link To: Media File” the resulting link points to a medium-sized image, instead of the full sized version.

    Is this intended behavior, and if so – how can I change it to always link to the full-size image?

    Thanks!

    • This topic was modified 7 months, 2 weeks ago by  Steve Stern. Reason: moved from developing to fixing
Viewing 6 replies - 1 through 6 (of 6 total)
  • Yeah… This is a problem for me. How do we link to the full size image in the Gallery block?

    godthor

    (@godthor)

    Same issue. I’ve also posted with no response on a solution.

    Ajkub

    (@pudliszewski)

    Some problem for me. Any ideas?

    I’ve started using the classic block to drop in a gallery instead of the gallery block. That way I get working functionality and everything from before. I use normal blocks for everything else, but classic for galleries; works great.

    Hey
    I found that if you are in edit mode for a blog post, you can click on the image and that opens a column to the right that includes details of the image. There is a section titled “Link Settings” which you can use to have the image linked to the media file. Took me a while to find this.

    @ptjones48 Thank you for doing the legwork. Saved me some time 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.