W3 Total Cache
Make fewer HTTP requests (6 posts)

  1. flekvtah
    Posted 3 years ago #

    Hi, I am having some trouble figuring out what settings I should use. I have the plug in installed but when I run YSlow I get an F on http requests.

    Grade F on Make fewer HTTP requests
    This page has 22 external Javascript scripts. Try combining them into one.
    This page has 15 external stylesheets. Try combining them into one.
    This page has 15 external background images. Try combining them with CSS sprites.

    Can someone help me figure out what settings will help with these areas.
    I would really appreciate the help.


  2. bheadrick
    Posted 3 years ago #

    enable minify.

    You might need to include the scripts manually to make sure they work.
    css will usually combine and minify with no issues
    There's nothing automatic to combine images into sprites (there are things that claim to do this, but aren't reliable). Your best bet in that arena is to create your sprites manually

  3. flekvtah
    Posted 3 years ago #

    Thanks for the reply. I will try that later today.

    Not sure if this next comment should be a different topic but it does relate to the W3 Total Cahce plug in. Having some buggy issues where I log in but do not see the wordpress bar at the top of the page and don't have an edit button on the page.

    Looks like I need to access things from the back end. This is not an ideal situation.
    Any thoughts on that.

  4. bheadrick
    Posted 3 years ago #

    sounds like maybe an issue with cookies or your cookiedomain is improperly set. I've seen that problem occasionally, but it didn't persist long enough to troubleshoot.

  5. flekvtah
    Posted 3 years ago #

    My cookie domain? I don't even know what that is.

    Interesting though. I was on a chat with the host yesterday afternoon because I had gotten a database error. I think now that is was because things were in motion – so to speak.

    Anyway she told me it looked normal on her end and she could see the toolbar.

    This morning I cleared my browsing data and deleted my cookies and still no bar. Is there something else I should be doing to my browser?

  6. bheadrick
    Posted 3 years ago #

    if it is a browser problem, try a different browser (other than IE) if you normally use chrome, use FF and vice versa.

    if it's fine for someone else, that does point to a local issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.