Support » Plugin: SpeakUp! Email Petitions » Make email message come from signer's name & email address not the site's?

  • Hi again Kreg.
    I noticed that if the email feature is enabled (sending the signed petition to the target), the email message appears coming from the website, and the website’s name appear as the sender’s name.

    Logically, it must be the signer’s email address, and his name (that he uses for signing the petition).
    Imagine if it was a complaint signature addressed to the head of a company by his angry employees. He will mark all petitions coming to his email as spam, which will make the email provider blacklist the website’s domain or email address.

    The solution is simply to have the signer’s details, not the website’s.

    2- is there a way to use a variable in the “email subject” option, like the signer’s name, so that, if John Martin signs the petition, the email that gets sent to the target would have the signer’s name in its subject, like “complaint from John Martin” , instead of simply “complaint”?
    If that’s possible, I would put this in the email subject option:
    “Complaint From [NAME]” , and that would put the signer’s name in place of the variable [NAME], which would be great.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I hope you find the time to answer my queries 🙂
    Thanks in advance
    (btw I responded to your comment here :

    Plugin Author Kreg Wallace


    What you describe is already the way the plugin works.

    The petition message email is sent using the name/email address of the person signing the petition.

    Emails from your site requesting users to confirm their signatures are sent from the website admin’s address by default. You can change the email address that confirmations are sent from on the Settings page.

    Hi. Thanks for sharing such a well designed plugin like SpeakUp!, and answering the questions from all over the world~

    However, I am a newbie to wordpress and php stuff. I have changed the email address that confirmations are sent from on the Settings page, but still the address shown is from the website server. What should I do?

    Dear Kreg. Then it seems there’s a bug in the emailing module.
    I was sure to put a unique email address in the signer’s email field.
    Yet when the signature and the message were delivered to the target, it appeared coming from WP’s default admin email address, not the address of the signer. This, although the correct email appeared in the text body, under the signature text.

    Also , the name of the signer didn’t appear in the subject’s line.

    What could be the reason ?




    I am having exactly the same problem. The emails are showing up as the website address. I downloaded the WP Mail SMPT plugin but that does not seem to help to input the senders address. Infact it will not override the website address at all.

    Great plugin. But I will not be able to use it if I can not figure this out. Does it have to be customized or is there paid support for the plugin?

    Any input would be appreciated.

    Thank you,


Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Make email message come from signer's name & email address not the site's?’ is closed to new replies.