Support » Plugin: In Stock Mailer for WooCommerce » Make button size & email input box wider

  • Resolved KoolPal

    (@koolpal)


    Hi,

    Please make the button size & email input box wider

    With a longer text and/or longer email ID it looks a bit messy

    Thanks

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Frank

    (@frankspress)

    Hi,
    I have already addressed this issue, will be fixed in the coming update.
    Normally the end user can fix it with custom css, but later on I’will probably implement a button size option, with small, medium and large, so that it can fit multiple themes and tastes.

    Thanks

    Frank

    • This reply was modified 7 months, 1 week ago by Frank.
    Plugin Author Frank

    (@frankspress)

    Alright, fix is up now. Please, make sure you clear your browser data to refresh the page. Let me know if that fixed your issue because I believe it’s theme related. Now it should be evenly squared.

    Frank

    Wow! Awesome work!

    I cleared browser cache and then checked again.

    Since I use Flatsome, I am not sure how much can you control this.

    Currently, the expanded button still looks like this:

    After some CSS tweaks

    and

    I managed to make it look like this:

    However, on mobile it still looks a bit weird like this:

    Is there anything you can tweak OR will I need to do this via Flatsome theme’s custom CSS?

    Once again, awesome stuff!

    Thanks

    Plugin Author Frank

    (@frankspress)

    Mmmhh, seems like the theme is imposing some CSS on it. Let me see if I can change that.
    Also just a heads-up, if you use font-awesome you get the icons in the button.

    Thanks! I will eagerly await your response.

    Also just a heads-up, if you use font-awesome you get the icons in the button.

    No I avoid font-awesome to skip the load issues. Thanks anyways I will keep this in mind for later.

    Once again, I really appreciate your support here! God bless you! 🙂

    Plugin Author Frank

    (@frankspress)

    Hi,
    No problem!
    I made some small changes and the mobile style should look much nicer.
    I also corrected the margin issue, and that should take care of your issue. Let me know if it worked.
    Thank you

    Frank

    KoolPal

    (@koolpal)

    @frankspress

    Awesome! This is perfect!

    On Desktop:

    On mobile:

    Awesome!

    Thanks a lot!

    @frankspress

    Hi, it’s me again!

    I had not updated this plugin since Version 1.2.5 and now once updated, I find this submit button size issue has cropped up again.

    Version 1.2.5 – All good

    Version 1.4.1 – button size issue

    I have tried changing Button Size but there is no impact.

    Please guide / fix.

    Thanks

    Plugin Author Frank

    (@frankspress)

    Hello,
    Thanks for reporting this issue.
    Could you please share a live link to the page so I can review and fix it permanently.
    Thanks

    @frankspress

    I updated the plugin on my local staging site

    I have not yet updated the plugin on the live site.

    Thanks

    Plugin Author Frank

    (@frankspress)

    The size is enforced already. Can you please open console and check where the styling is coming from ?

    Yes, this issue is coming due to the 9px padding

    If I uncheck 9px padding, then the button looks normal

    I use Flatsome theme, if it helps

    Thanks

    Plugin Author Frank

    (@frankspress)

    Reload and try unchecking “min-height: 2.5em”, let me know if that fixes it.

    No, there was no difference after unchecking “min-height: 2.5em”

    Plugin Author Frank

    (@frankspress)

    Disable line-height and min-height altogether. If that works also click on the email field, there might be a height or max-height that is containing the field.
    If that solves it then I’ll update accordingly.

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.