Support » Fixing WordPress » Major problems with the visual editor and no solutions yet

  • Resolved wingzfly


    Hi all!

    So I’ve been having a problem for several days now and I reached out a few days ago here and got a couple of replies, but the people who were trying weren’t able to figure it out. (Though they were VERY helpful and I’m grateful for their time and for attempting to help.)

    Here’s the issue:

    I’m the webmaster for the site at The problem is four-fold:

    1) The “Visual” tab in the editor is selected, but there appears to be nothing inside the text box, certainly nothing “visual.” Instead, it’s all HTML in a white font color on a white background, so it appears blank. (I can see the “hidden” html text in the body of the editor when I highlight it all so I know it’s there.)

    2) I can’t click back and forth between the “visual” and “html” tabs.

    3) None of the editor’s normal formatting buttons show up. (The bold, italics, etc. row is gone.)

    4) I can’t seem to open any of the other pull-down menus on the editing pages, meaning I can click the triangle at the top of the “publish” “screen options,” or “help” boxes, for example, but it doesn’t do anything. (I CAN, however, use those pull-down menus on any other page, like the Appearance page or the Media Library page. They only don’t respond in the edit post and edit page pages.)

    From what I’ve read, it sounds like the problem may be related to TINY MCE, since the dashboard and everything else seems to work and the problems appear to be limited to the editor.

    What I’ve tried so far:

    I’ve tried disabling all the plugins, including renaming the plugin directory and ultimately uninstalling ALL plugins and making sure the plugin directory is completely empty. Hasn’t worked.

    I’ve tried changing themes over to the Twenty Fourteen theme and that doesn’t help. I still have those problems on the default theme.

    I’ve tried reinstalling WordPress 3.9.2 twice automatically (via my host’s script) and three times manually but that hasn’t helped. (I deleted everything but the wp-config file and the wp-content directory.)

    I’ve tried it on various browsers (IE9, the latest version of Chrome, Safari, and the latest version of Firefox) and on several different computers and the results are the same on each.

    I’ve tried editing the php.ini file to disable “Magic Quotes” as someone said that worked for them. It didn’t work for me so after testing it, I restored the original, clean php.ini file.

    I’ve cleared all caches several times but no dice.

    I also recently found this coming up as an error in the debug section of Chrome’s inspect element option. The errors come up when I try to click on the “Visual” and “HTML” tabs in the editor:

    Uncaught ReferenceError: switchEditors is not defined post.php?post=477&action=edit:275

    Uncaught ReferenceError: switchEditors is not defined post.php?post=477&action=edit:276

    So again it may be a TINYMCE thing or it may have something to do with whatever is supposed to allow me to switch between those tabs and interact with all of the various other tabs/pull-downs on the editing pages.

    I can’t figure out what else to try, so I’d love some input, ideas, advice, etc.

    Thanks in advance to you all for your help and time.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Figured it out! It turns out there were two overly-large (5 MB) jpgs in the media library and it caused some sort of memory corruption. Once I removed the two jpgs, the editor worked correctly.

    Thanks to MacManX and everyone else that helped!

    Moderator James Huff


    Halfelf Minion 🚀

    Just tying this all together, conversation started at:

    Awesome, I’m glad you found the problem, and that is indeed a odd problem! Were you able to re-upload those two images without issue?

    I left it up to my client whether or not they wanted to risk uploading them again but warned them that there was no reason at all to upload an image that was 11,000+ pixels wide and probably three or four times that height because it wouldn’t display that way on any display.

    It’s nice to at least have figured out what it was. I felt like my brain was going to explode trying to figure out what it could be. haha Again, man, thanks so much for your help!

    Moderator James Huff


    Halfelf Minion 🚀

    You’re welcome! 🙂

    The problem was solved in my wordpress installation when I created a new user (administrator). So the problem was user related I assume…

    Moderator James Huff


    Halfelf Minion 🚀

    Akkon, perhaps just yours. Different problems have different solutions. 🙂

    I have 5 different web sites on different hosting servers and different domains and each and every one of them has this problem. I’ve just checked one for large images and there are none! 🙁

    Moderator James Huff


    Halfelf Minion 🚀

    I did the same and it’s working well. I didn’t identify which file was but it’s works. Thanks

    Moderator James Huff


    Halfelf Minion 🚀

    You’re welcome!

    Hi. I have just solved my similar problem – I had updated to 3.9.2 and also added a new theme and couldn’t get either the “text” or “visual” tabs to show on the page/post editor. Tried changin themes, disabled then deleted all plugins, updated php on my hosting. Was stuck! Then saw soething about users so checked and I have 2 admins and was logged in as one I hardly ever use (don’t know how that happened) and upon check his roles the “disable the visual editor when writing” was checked. Unchecked and all working !! Hope this may help someone

    Wingzfly how were you able to find the large jpg. files? We are having the same problem.

    Musiczoo, I just looked in the media library. If you click on each file, WordPress gives you more info on them, including the dimensions. (It might even give you the file size; I’m not at the computer, so I can’t remember off the top of my head.) I noticed the dimensions for the two files the user uploaded were massive, so I saved them to my computer (just in case he didn’t have any copies) and then deleted them from the media library.

    Ok, sounds good. Thanks for the help!

    I tried to create a new admin account, and that didn’t help. I also try to check the media files and nothing comes up at all. I have pictures on my site, but I can’t even get a list of them. Help! And, thanks for all of the suggestions.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Major problems with the visual editor and no solutions yet’ is closed to new replies.