Support » Installing WordPress » Major problem with upgrade to 2.0.2

  • I just tried to upgrade from 2.0 to 2.0.2. The upgrade script says:

    Warning: array_filter(): The second argument, ‘Array’, should be a valid callback in /opt/blog/wp-includes/capabilities.php on line 152

    Warning: Invalid argument supplied for foreach() in /opt/blog/wp-includes/capabilities.php on line 156

    Warning: Cannot modify header information – headers already sent by (output started at /opt/blog/wp-includes/capabilities.php:152) in /opt/blog/wp-admin/upgrade.php on line 10

    I started the upgrade anyway. When I start the admin interface I get:

    Warning: array_filter(): The second argument, ‘Array’, should be a valid callback in /opt/blog/wp-includes/capabilities.php on line 152

    Warning: Invalid argument supplied for foreach() in /opt/blog/wp-includes/capabilities.php on line 156
    Du hast nicht ausreichend Rechte, um auf diese Seite zuzugreifen.

    Any idea? Thanks…

Viewing 3 replies - 1 through 3 (of 3 total)
  • Have you tried to re-upload the new files and try again? Also, “header already sent” is generally a blank space before the opening PHP tag or after the closing PHP tag in a file. Did you do some manual changes to any of the files prior to uploading them?

    My upgrade went off without a hitch.

    Thanks a lot! It seems you were right. I downloaded and uploaded again and now it works perfectly fine. I hope I didn’t trouble anybody. Sorry…

    Glad it worked out! And no, you didn’t trouble anybody; that’s what community support is all about, and you can join in and help others in the future with your new-found experience! 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Major problem with upgrade to 2.0.2’ is closed to new replies.