Support » Plugin: Jetpack by WordPress.com » Major Problem with Jetpack

  • Resolved Strictly Software

    (@strictly-software)


    Hi

    I have had to turn Jetpack off to find out that it was the cause of a problem I have been having for a while now.

    I use a combination of plugins to get content onto my site and then out to social media sites.

    I have a C# app that emails posts into my site, a CRON job calls a plugin called POSTIE that converts these to articles with custom categories and tags.

    My Strictly TweetBOT then runs and sends these tweets out to various twitter accounts which are linked to Facebook pages.

    However over the last few months, usually after a WP or Jetpack update, I have always experienced problems where either of the following happens.
    -The emailed posts don’t get converted to articles. They stay as drafts with tmpTitle and tmpPost as the title/content. This means no tweets either.
    -My Strictly AutoTags plugin which automatically tags the most relevant words in an article, deeplinks words and bolds them for SEO etc doesn’t run.
    -As my TweetBOT is auto linked to the AutoTags plugin, so it only runs when the tagging has finished (to prevent empty tweets going out with no tags used as #hastags) – this means that as the tagging never finishes and sets a custom meta for the post which fires an action/event that the TweetBot is linked to. The Tweets don’t go out.
    -Also none of your other social media works Google+, LinkedIn, Tumblr etc.

    I did the old, turn all your plugins off and on one by one until you find the one that is causing the problem and it was Jetpack. There are a couple of my posts on the Postie Plugin forum if you want to see the problems I have had.

    I have no idea why this is happening or why your plugin would cause this to happen OR anyway to debug and find out either.

    Any ideas as I miss being able to send my articles to Google+ and LinkedIn etc.

    Thanks

    Rob

    https://wordpress.org/plugins/jetpack/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I think we’ve discussed about these issues in the past, in this thread.

    Could you follow the instructions I posted there to send us more details about your site?

    Thanks!

    Hi

    Thanks for replying.

    However seeing that two of the plugins involved are my own (I wrote them) – Strictly AutoTags and Strictly TweetBOT I know the author (me) and there is nothing wrong with the code and it hasn’t changed for quite a while now.

    As for the Postie plugin I have been in contact with the author and he told me to disable all plugins one by one and see which one made it work again. I did that and Jetpack was the plugin that caused the problem.

    At first I thought it was a problem with Postie or out of memory issues during tagging but I can run it manually (from within the site) and it will work every time. It is only when it runs automatically e.g a C# application sends in emails to be turned into Posts by Postie that are then tagged and tweeted out that the problems occur.

    There is no problem sending the emails to the server or picking them up. Tried rebooting the mail servers. And when there is an email ready in the queue I can run Postie manually to get it to run fine.

    Obviously I want it to run automatically which it has done for ages.

    I have no idea which part of Jetpack is causing the problems but the only part I really need is the social media sharing e.g posting to Google+ and LinkedIn etc.

    I will have to look for another tool to send out posts to these sites.

    If there is anything else I can do let me know.

    Thanks

    Rob

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I have no idea which part of Jetpack is causing the problems but the only part I really need is the social media sharing e.g posting to Google+ and LinkedIn etc.

    Could you send us more details about your site using the steps I mentioned in the other thread. Here they are again:

    1) Go to the Jetpack page in your dashboard.
    2) Click on the Debug link appearing at the bottom of the page.
    3) Click the link that says “click here to contact Jetpack support.”
    4) Fill in the description box and your name and email address.
    5) Click the “Contact Support” button.

    Thanks!

    Hi

    Thanks for the reply I received however I am unsure of what to ask for. Maybe if you read through how my own plugins work you could suggest some sort of request I could put to the Jetpack team as I am sure they won’t accommodate my own hooks/actions in their plugin.

    The email I got is below.

    Hi Rob!

    > Therefore I am thinking your plugin and others like it are doing calls on the
    > publish_post hook and this is causing no tagging to be done or tweets to go out
    > even if your social media posts go out.

    Here’s what I suggest: have a look at the Publicize code (at least, what’s in the plugin, since a lot of Publicize happens on the WordPress.com side of things).

    https://github.com/Automattic/jetpack/blob/master/modules/publicize/publicize.php#L68

    We hook into the transition_post_status hook; when a post goes from draft or unsaved to Published, that’s when we start saving the related Post-meta as you mentioned.

    If you don’t find an adequate place in the plugin that you can hook into for what you’re doing with your own plugins, then please open up an enhancement request here:

    https://github.com/Automattic/jetpack/issues/new

    and specify that you’d like a hook added to the plugin, and where exactly.

    Does that help?

    So I know 100% turning the Publicize code off fixes the problem I was having with emails being turned into posts (with the Postie plugin) and then social media going out and my posts getting tagged with Strictly AutoTags and then Tweeted with Strictly TweetBOT.

    What I don’t know is how to re-arrange the way my two plugins interact as they rely on custom hooks/actions. If I need to ask for a new feature in Jetpack I need some help in figuring out what I need to ask for.

    I have an Auto Tagger Plugin (Strictly AutoTags) that the save_post action fires (draft/publish) to tag the post.

    After the tagging is complete I need Jetpacks Publicize event to fire sending out the messages to Google+, Tumblr, LinkedIn etc.

    Due to the high number of tags I have on my site 25,000+ just changing the priority order doesn’t work to ensure tweets or other messages are sent out AFTER the tagging is done.

    On small sites it might.

    However I have to re-save the newly tagged and reformatted post back into the DB before calling my other plugin Strictly TweetBOT (that fires tweets using tags as #hashtags to numerous accounts).

    So what happens is that after the post is first saved and on_save runs

    -I re-open the post and do the tagging before re-saving it using SQL only.

    -I set a finished_doing_tagging action/event with the post_id so other plugins can run off it e.g my TweetBot. It would be nice if I could get Jetpack to also hook into this action to fire off its messages to LinkedIn/Tumblr/Google+ etc.

    // fire my custom event so any plugin wanting to run when tagging is completed can now do so pass in the post ID as the parameter so others can use it
    do_action('finished_doing_tagging', $object->ID);

    -Then my Strictly TweetBOT plugin uses the publish_post action to call a function CheckAndPostTweets which checks for the existence of AutoTags to decide whether to wait for the end of tagging or to run ASAP.

    add_action( 'publish_post', array($this, 'CheckAndPostTweets') , 999);

    This function works out whether AutoTags is installed.

    If not it just runs and sends the tweets.

    If it is installed then it adds our PostTweets function to the finished_doing_tagging hook/event.

    if($strictly_auto_tags_active ){
    
    	// AutoTags is active - have we tweeted already?
    
    	$tweeted_already = get_post_meta($post_id, 'strictlytweetbot_posted_tweet', true);
    
    	if(!$tweeted_already){
    		// Strictly AutoTags is loaded so wait until the finished_doing_tagging event fires for $post_id
    
    		// hook post_tweets into our finished_doing_tagging HOOK/EVENT
    		add_action('finished_doing_tagging',array($this, 'PostTweets'),99,1);
    	}else{
    		// Strictly AutoTags is loaded but we have already tweeted! so RETURN FALSE!
    
    		return;
    	}
    }else{
    
    	// no Strictly AutoTags and no tags/categories so just post tweets now for $post_id
    
    	// just run normal tweet code
    	$this->PostTweets($post_id);
    }

    Once Tweeting is complete I set some post meta to tell me that this post has had the tweetbot code run against it. Which you can see being used in the above code snippet to determine whether Tweeting has already run for this post.

    // after tweeting we set the event strictlytweetbot_posted_tweet so we know we have posted tweets for this post id
    add_post_meta($post_id, 'strictlytweetbot_posted_tweet', '1', true);

    So somewhere I need to ask JetPack to get their Publicize code to run on the same hook I have e.g finished_doing_tagging.

    Or (as I doubt they will change their code to fit in with MY plugins) arrange the order of events in such a way that I can fire their publicize function once my tagging is complete.

    As for why their Publicize action is effecting the change of Posties posts from temporary posts to real ones I have no idea unless it’s my tagging plugin effecting it in someway.

    If you have any ideas I would love to hear them.

    Thanks!

    Plugin Contributor Ryan Cowles

    (@ryancowles)

    Thanks for the additional info, Rob! It sounds like you’re running a very custom setup. I’m afraid that supporting such a custom publishing flow is out of scope of the support that we can provide.

    Instead, I would recommend searching for another plugin that offers similar functionality:
    https://wordpress.org/plugins/

    You might have to register your own app ID when using another plugin, but you should be able to hook into it as needed.

    I hope this helps to point you in the right direction!

    Yeah it seems that any kind of social media plugin has the same issue as I’ve tried a few now.

    For some reason it reacts with Postie (not my Plugin) that converts emails to posts causing them to become drafts only, if this happens no tagging and therefore no tweeting.

    So are you 100% sure there is no check I could run in my TweetBot plugin that Tweets on_publish once Tagging is complete to see if:
    -JetPack was installed e.g check plugins array, or some custom function existing.
    -And if so, call your own Publicize method manually from there?

    It was all working fine for 3 years and then something happened to just stop it working.

    My plugins haven’t changed for a while, only the number of the tags in the site which I trim down regularly if they have less than 4 posts against them.

    Only Jetpack and WP core code has really changed that caused this so I don’t really know what happened as if you are posting on a transition from draft to publish then it shouldn’t really matter what my own plugins are doing on the same actions should it?

    Anyway thanks for your help and if you can think of any suggestions please do not hesitate to let me know.

    Thanks

    Rob

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Major Problem with Jetpack’ is closed to new replies.