Support » Fixing WordPress » Major issue with image sizes being lost, only full size images being shown

  • I’m seriously stuck with an issue on WordPress. It appears my serialised data has gotten messed up, I think, in the postmeta table where meta_key = _wp_attachment_metadata

    I’m totally baffled.

    The issue is essentially the same as this thread:

    but the answers there don’t seem to be working for me.

    So I’ve got where I was working on the new design for my site. All good there.

    I moved, in my standard way, everything back over to and now none of my image thumbnails are loading. It’s only loading the full size images.

    I’ve compared the most recent photoblog upload in the two databases and can’t see anything wrong.

    I’ve tried changing paths in options, I’ve tried this serialisation fixer:

    I’ve tried rebuilding my thumnails.

    I’ve re-exported the database, redone the standard find and replace on ->

    I’m completely at a loss, and the idea of deleting all these images and reuploading them is painful.

    The only thing that looks unusual to me is that on, the postmeta->meta_key->_wp_attachment_metadata actually contains references to /server/path/to/

    Obviously when I do a search and replace on the database of -> this doesn’t affect those serialised entries. Both devel and live versions are living on the same server, so I assume that’s why works even though it’s referencing the /server/path/to/ instead of /server/path/to/ but I don’t understand why, when moving it back to the live domain it suddenly loses the ability to connect to the thumbnail sizes of those images.

    I’m really stuck on this and can’t see how to fix this. And now my live domain is loading these huge original sized images which looks awful.

    Any help would be hugely appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Please remove above links, the site contains malware.

    Thread Starter alexleonard


    Hi Swanson Photos,

    I have no idea how it thinks that. The folder it has flagged is:

    This folder contains a load of pdf files and zips with pdf files in them. MD-Panels-080911-outlined-text.pdf
    MD-A5-Leaflet-110911-outlined-text.pdf MD_A5_Leaflet_290911_Irish_large.pdf MD_A5_Leaflet_290911_Irish.pdf MD_Flag.pdf MD_Posters_21x48_FA_080911_Irish_A4.pdf

    I’ve deleted this folder anyway and any other files and zips in the root just in case. is still saying the root folder has malware, but perhaps it hasn’t rescanned, but I can only assure you that’s wrong.

    Anyway, I’m only linking to which is verified clean:

    I hope that clears everything up. Obviously I take any malware threat as extremely important. This is our own server and is regularly scanned for a huge variety of insecurities. I hope that reassures you.

    Do you think you have any idea what might be wrong?

    It looks like there are some locked folders in your public html area…review that…I cannot visit site until securi notes it is clean.

    You should work with haste to resolve this, maybe even take site down for now (just upload a .maintenance file), as you can get blacklisted.

    Ask your host to take a peak also as they may have some advanced tools…

    and read this:

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Plugin Review Team Rep

    Delinked. Scan your site for malware and ask your host for help ASAP.

    (And Swanson means he will not visit your site till it’s clean, which is true of a lot of us. We can, we just won’t.)

    Yup, I could…but, I shall not until…

    @ Iptensu, Thanks

    Thread Starter alexleonard


    Hey guys,

    Sorry for the delay in getting back to you. I was out last night.

    The root for the devel subdomain is now ‘clean’

    Apparently it’s a potential malware site if we’ve disabled directory listing. To get it changed from malware to not malware I had to create an index.html file

    We run our own server and I take suggestions that we’ve got malware very seriously. I was a little slow yesterday to realise that the reason it was throwing an error was because I didn’t have an index.html file.

    So anyway, I hope you’re happy that it’s all clear now and if there’s any suggestions you have about this issue I’m having, I’d be hugely hugely appreciative of your assistance. It’s really put a downer on my new site launch 🙁

    @ipstenu can I re-instate the links in the original post?

    Thread Starter alexleonard


    I do find it funny that our own security measure of disabling directory listing in apache gets us marked as potentially harbouring malware. I’d be far more suspicious of the security of a host that allows directory listing to folders without an index file.

    However I also appreciate that you need to take these things seriously at your end. Cheers!

    Hiding public files is not how this is accomplished…hiding behind a proxy may be…there are many here in the community who can advice you on this topic, I suggest you seek their advice.

    Thread Starter alexleonard


    @swansonphotos sucuri now shows our site as clean. Clearly their system, when seeing an empty root folder which has directory listing disabled (eg returning 403), then returns a malware warning.

    Here’s an example:

    1. No Malware warning: – ok – verified clean

    2. Let’s have a look at my theme’s images folder (an empty folder on our server): – this returns a 403 forbidden warning.

    3. Now, let’s get to scan this URL: – Big red warning – site infected with malware.

    If I upload an index.html file to this directory will now return that this url is clean.

    I would like you to accept that is definitely wrong in this instance. Their error warning is:

    This error happens when your hosting company (Bluehost, Hostmonster, GoDaddy, etc) disabled your site due to security or payment reasons.

    It can also happen if the site went down or is within a maintenance Window. If you get this warning, try to run a real time scan here: to see if the problem remains.

    So, because we’ve decided to return 403 forbidden errors when someone tries to browse a directory with no index.html/php file in it (disabled directory listing), is assuming that we’re some generic hosting company that would always allow directory listing in apache.

    Our server is clean. And I’m no closer to finding a result to this issue and I’d understand if no one wanted to touch this thread even though I have a valid and extremely confusing WordPress issue and a site that is definitely not infected with malware.

    Thread Starter alexleonard


    Right, well I’ve finally found some more time to investigate and I’m going to post my findings here. So I’ve uploaded some new images to the system and, as expected, they work without an issue.

    So here’s a working image, newly uploaded:

    |   30128 |   28724 | _wp_attachment_metadata | a:6:{s:5:"width";s:4:"1920";s:6:"height";s:4:"1280";s:14:"hwstring_small";s:23:"height='85' width='128'";s:4:"file";s:28:"2012/01/statues-IMG_6277.jpg";s:5:"sizes";a:14:{s:9:"thumbnail";a:3:{s:4:"file";s:28:"statues-IMG_6277-200x133.jpg";s:5:"width";s:3:"200";s:6:"height";s:3:"133";}s:6:"medium";a:3:{s:4:"file";s:28:"statues-IMG_6277-710x473.jpg";s:5:"width";s:3:"710";s:6:"height";s:3:"473";}s:5:"large";a:3:{s:4:"file";s:29:"statues-IMG_6277-1280x853.jpg";s:5:"width";s:4:"1280";s:6:"height";s:3:"853";}s:9:"rss-thumb";a:3:{s:4:"file";s:28:"statues-IMG_6277-400x266.jpg";s:5:"width";s:3:"400";s:6:"height";s:3:"266";}s:19:"standard-list-thumb";a:3:{s:4:"file";s:28:"statues-IMG_6277-160x160.jpg";s:5:"width";s:3:"160";s:6:"height";s:3:"160";}s:15:"home-post-thumb";a:3:{s:4:"file";s:26:"statues-IMG_6277-75x75.jpg";s:5:"width";s:2:"75";s:6:"height";s:2:"75";}s:16:"photo-grid-thumb";a:3:{s:4:"file";s:28:"statues-IMG_6277-230x230.jpg";s:5:"width";s:3:"230";s:6:"height";s:3:"230";}s:19:"wallpaper-1920x1200";a:3:{s:4:"file";s:30:"statues-IMG_6277-1920x1200.jpg";s:5:"width";s:4:"1920";s:6:"height";s:4:"1200";}s:19:"wallpaper-1920x1080";a:3:{s:4:"file";s:30:"statues-IMG_6277-1920x1080.jpg";s:5:"width";s:4:"1920";s:6:"height";s:4:"1080";}s:19:"wallpaper-1680x1050";a:3:{s:4:"file";s:30:"statues-IMG_6277-1680x1050.jpg";s:5:"width";s:4:"1680";s:6:"height";s:4:"1050";}s:18:"wallpaper-1440x900";a:3:{s:4:"file";s:29:"statues-IMG_6277-1440x900.jpg";s:5:"width";s:4:"1440";s:6:"height";s:3:"900";}s:18:"wallpaper-1366x768";a:3:{s:4:"file";s:29:"statues-IMG_6277-1368x768.jpg";s:5:"width";s:4:"1368";s:6:"height";s:3:"768";}s:19:"wallpaper-1280x1024";a:3:{s:4:"file";s:30:"statues-IMG_6277-1280x1024.jpg";s:5:"width";s:4:"1280";s:6:"height";s:4:"1024";}s:18:"wallpaper-1280x800";a:3:{s:4:"file";s:29:"statues-IMG_6277-1280x800.jpg";s:5:"width";s:4:"1280";s:6:"height";s:3:"800";}}s:10:"image_meta";a:10:{s:8:"aperture";s:3:"1.4";s:6:"credit";s:12:"Alex Leonard";s:6:"camera";s:14:"Canon EOS 550D";s:7:"caption";s:86:"A statue over the doorway of one of the churches in Ballycastle. Well lit up at night.";s:17:"created_timestamp";s:10:"1325525994";s:9:"copyright";s:0:"";s:12:"focal_length";s:2:"50";s:3:"iso";s:3:"400";s:13:"shutter_speed";s:5:"0.005";s:5:"title";s:7:"Statues";}} |
    |   30127 |   28724 | _wp_attached_file       | 2012/01/statues-IMG_6277.jpg

    and here’s a broken image.

    |    4799 |   25410 | _wp_attachment_metadata | a:6:{s:5:"width";s:3:"480";s:6:"height";s:3:"391";s:14:"hwstring_small";s:23:"height='96' width='117'";s:4:"file";s:32:"2011/06/google-vs-rapportive.jpg";s:5:"sizes";a:14:{s:9:"thumbnail";a:5:{s:4:"file";s:32:"google-vs-rapportive-200x162.jpg";s:5:"width";s:3:"200";s:6:"height";s:3:"162";s:4:"path";s:40:"2011/06/google-vs-rapportive-200x162.jpg";s:3:"url";s:102:"";}s:6:"medium";s:0:"";s:5:"large";s:0:"";s:9:"rss-thumb";a:3:{s:4:"file";s:32:"google-vs-rapportive-400x325.jpg";s:5:"width";s:3:"400";s:6:"height";s:3:"325";}s:19:"standard-list-thumb";a:5:{s:4:"file";s:32:"google-vs-rapportive-160x160.jpg";s:5:"width";s:3:"160";s:6:"height";s:3:"160";s:4:"path";s:40:"2011/06/google-vs-rapportive-160x160.jpg";s:3:"url";s:102:"";}s:15:"home-post-thumb";a:5:{s:4:"file";s:30:"google-vs-rapportive-75x75.jpg";s:5:"width";s:2:"75";s:6:"height";s:2:"75";s:4:"path";s:38:"2011/06/google-vs-rapportive-75x75.jpg";s:3:"url";s:100:"";}s:16:"photo-grid-thumb";a:5:{s:4:"file";s:32:"google-vs-rapportive-230x230.jpg";s:5:"width";s:3:"230";s:6:"height";s:3:"230";s:4:"path";s:40:"2011/06/google-vs-rapportive-230x230.jpg";s:3:"url";s:102:"";}s:19:"wallpaper-1920x1200";s:0:"";s:19:"wallpaper-1920x1080";s:0:"";s:19:"wallpaper-1680x1050";s:0:"";s:18:"wallpaper-1440x900";s:0:"";s:18:"wallpaper-1366x768";s:0:"";s:19:"wallpaper-1280x1024";s:0:"";s:18:"wallpaper-1280x800";s:0:"";}s:10:"image_meta";a:10:{s:8:"aperture";s:1:"0";s:6:"credit";s:12:"Alex Leonard";s:6:"camera";s:0:"";s:7:"caption";s:0:"";s:17:"created_timestamp";s:10:"1309363357";s:9:"copyright";s:0:"";s:12:"focal_length";s:1:"0";s:3:"iso";s:1:"0";s:13:"shutter_speed";s:1:"0";s:5:"title";s:0:"";}} |
    |    4798 |   25410 | _wp_attached_file       | 2011/06/google-vs-rapportive.jpg

    I’m finding it next to impossible to work out what’s going on with this serialised data. They look pretty similar to me, however the one thing I’ve noticed that is in the broken image is mention of “path”. The working image doesn’t mention “path” at all in its serialised data.

    Anyone any thoughts? I don’t think I can just go deleting the path part of the _wp_attachment_metadata, and I’m not even sure how I’d go about programatically doing that.

    Thread Starter alexleonard


    I actually can’t work this out at all.

    I think I might just go through and re-upload images to posts that have either a featured image or a gallery. Any other posts with images embedded in the post are fine as that’s a hard-coded src on the img element.

    I’ve only got 13 posts with galleries, sadly I have 100 posts with featured images set.. but at least I have post id’s from a handy wee SQL query so I can just go through them one at a time.

    I had hoped I could fix this with some sort of genius SQL query, but I don’t know where to start.

    Sorry to have failed to provide any answer.

    If anyone can think of an answer, I’d be delighted to hear it though, in case this ever happens in the future and in case the answer arrives before I finish manually doing things..

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Major issue with image sizes being lost, only full size images being shown’ is closed to new replies.